Bug 1410969 - NetworkManager comes up on boot, but a restart of the service fails to activate bond slaves
Summary: NetworkManager comes up on boot, but a restart of the service fails to activa...
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager
Version: 7.2
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Beniamino Galvani
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-07 01:06 UTC by mcolombo
Modified: 2017-01-12 08:43 UTC (History)
9 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-01-12 01:58:54 UTC


Attachments (Terms of Use)

Description mcolombo 2017-01-07 01:06:53 UTC
Created attachment 1238146 [details]
/var/log/messages with NetworkManager debug enabled

Description of problem:

NetworkManager comes up on boot, but a restart of the service fails to activate bond slaves

Version-Release number of selected component (if applicable):

 NetworkManager-1.0.6-31.el7_2.x86_64
 kernel-3.10.0-327.41.4.el7.x86_64

How reproducible:

Always

Steps to Reproduce:
1.Boot
2.systemctl restart NetworkManager.service


Actual results:
 
Restart fails and networking stays down

Expected results:

Restart works and networking comes up

Additional info:

sosreport for config files, and messages file with NM debug logging, to be added as private attachments

Comment 1 mcolombo 2017-01-07 01:10 UTC
Created attachment 1238147 [details]
Most recent sosreport

Comment 3 Beniamino Galvani 2017-01-09 08:46:46 UTC
Note that the best way to apply the changes done to a connection is by
reactivating it with:

 nmcli connection up <connection name or uuid>

or using the "Activate a connection" menu of nmtui. If the changes
were made directly on ifcfg files you should tell NM to reload the
connections (before the previous command):

 nmcli connection reload

Restarting NM may causes issues in some cases because NM tries to
detect which connections were previously active and this doesn't
always work correctly. We have planned to rework this area for 7.4 and
change how connections are handled upon restart, see bug 1394579.

Anyway, while the issue is reproducible on RHEL 7.2 (NM 1.0.6-31), it
doesn't happen on RHEL 7.3 (NM 1.4.0-13) as bond slaves properly come
up after the service restart.

Comment 4 Jamie Bainbridge 2017-01-09 22:54:39 UTC
Thank you, nmcli con reload and con down/up are working fine.

Is there any chance of getting those NM link detection patches backported to 7.2.z, or are the changes between 1.0.6 and 1.4.0 too large? If it can be done, we'll make a formal z-Stream request.

Comment 5 Beniamino Galvani 2017-01-10 13:12:52 UTC
(In reply to Jamie Bainbridge from comment #4)
> Thank you, nmcli con reload and con down/up are working fine.
> 
> Is there any chance of getting those NM link detection patches backported to
> 7.2.z, or are the changes between 1.0.6 and 1.4.0 too large? If it can be
> done, we'll make a formal z-Stream request.

Sorry, due to the amount of changes between 1.0.6 and 1.4.0, the
commits can't be cleanly backported and require many other patches
that are out of scope for 7.2.z and would compromise stability.

Comment 6 Jamie Bainbridge 2017-01-10 22:20:24 UTC
No worries, thank you for the reply. Give me a few days and I'll likely move this one to CLOSED NOTABUG. Needinfo on myself for that.


Note You need to log in before you can comment on or make changes to this bug.