Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1411027 - fedora-packager has unsatisfiable dependencies in epel6
Summary: fedora-packager has unsatisfiable dependencies in epel6
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: fedora-packager
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dennis Gilmore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-07 16:09 UTC by Tom Lane
Modified: 2017-01-26 13:26 UTC (History)
3 users (show)

Fixed In Version: fedora-packager-0.6.0.1-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 11:46:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Lane 2017-01-07 16:09:41 UTC
Description of problem:
Running a routine "yum update" this morning on a RHEL6 machine, I get

---> Package fedora-cert.noarch 0:0.5.10.7-1.el6 will be updated
---> Package fedora-cert.noarch 0:0.6.0.0-1.el6 will be an update
---> Package fedora-packager.noarch 0:0.5.10.7-1.el6 will be updated
---> Package fedora-packager.noarch 0:0.6.0.0-1.el6 will be an update
--> Processing Dependency: krb5-workstation >= 1.14.3-4 for package: fedora-packager-0.6.0.0-1.el6.noarch
--> Processing Dependency: python-yubico for package: fedora-packager-0.6.0.0-1.el6.noarch
---> Package fedpkg.noarch 0:1.24-3.el6 will be updated
---> Package fedpkg.noarch 0:1.26-4.el6 will be an update
...
Error: Package: fedora-packager-0.6.0.0-1.el6.noarch (epel)
           Requires: python-yubico
Error: Package: fedora-packager-0.6.0.0-1.el6.noarch (epel)
           Requires: krb5-workstation >= 1.14.3-4
           Installed: krb5-workstation-1.10.3-57.el6.x86_64 (@rhel-6-workstation-rpms)


Version-Release number of selected component (if applicable):
fedora-packager-0.5.10.7-1.el6.noarch is the installed version

How reproducible:
Probably 100%, but I didn't actually try to repeat it

Steps to Reproduce:
1. sudo yum update

Actual results:
fail

Expected results:
success

Additional info:

Comment 1 Fedora Update System 2017-01-09 22:30:25 UTC
fedora-packager-0.6.0.1-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-3cc24b7566

Comment 2 Fedora Update System 2017-01-10 11:46:13 UTC
fedora-packager-0.6.0.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 3 manuel wolfshant 2017-01-10 12:18:09 UTC
As of Jan 10, the required bits ( as described in https://bugzilla.redhat.com/show_bug.cgi?id=1411027#c0 ) are in epel-testing, not in epel-stable.

Comment 4 Tom Lane 2017-01-11 12:49:42 UTC
fedora-packager-0.6.0.1-1.el6.noarch is still broken:

--> Finished Dependency Resolution
Error: Package: fedora-packager-0.6.0.1-1.el6.noarch (epel)
           Requires: python-yubico
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 5 Tom Lane 2017-01-26 13:26:02 UTC
As of this morning, "yum update" succeeds --- looks like python-yubico is now available in epel 6.  So this is fixed, thanks.


Note You need to log in before you can comment on or make changes to this bug.