Bug 1411049 - Scriptlets fail
Summary: Scriptlets fail
Keywords:
Status: CLOSED DUPLICATE of bug 1340507
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-07 21:12 UTC by darrell pfeifer
Modified: 2017-01-11 22:57 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 22:57:02 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1392236 0 unspecified CLOSED systemd-232 broke composing 2021-02-22 00:41:40 UTC

Internal Links: 1392236

Description darrell pfeifer 2017-01-07 21:12:31 UTC
Description of problem:

Running transaction
  Upgrading   : systemd-libs-232-6.fc26.x86_64                                                                            1/18 
  Upgrading   : systemd-pam-232-6.fc26.x86_64                                                                             2/18 
  Upgrading   : systemd-232-6.fc26.x86_64                                                                                 3/18 
  Upgrading   : systemd-udev-232-6.fc26.x86_64                                                                            4/18 
  Upgrading   : systemd-container-232-6.fc26.x86_64                                                                       5/18 
  Upgrading   : python3-cffi-1.9.1-1.fc26.x86_64                                                                          6/18 
  Upgrading   : python2-cffi-1.9.1-1.fc26.x86_64                                                                          7/18 
  Cleanup     : systemd-container-232-5.fc26.x86_64                                                                       8/18 
  Cleanup     : systemd-udev-232-5.fc26.x86_64                                                                            9/18 
  Cleanup     : systemd-pam-232-5.fc26.x86_64                                                                            10/18 
  Cleanup     : systemd-232-5.fc26.x86_64                                                                                11/18 
/var/tmp/rpm-tmp.xAYMhh: line 1: fg: no job control
error: %preun(systemd-udev-232-3.fc26.x86_64) scriptlet failed, exit status 1
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/dnf/yum/rpmtrans.py", line 427, in callback
    self._scriptError(amount, total, key)
  File "/usr/lib/python3.6/site-packages/dnf/yum/rpmtrans.py", line 551, in _scriptError
    name = pkg.name
AttributeError: 'NoneType' object has no attribute 'name'
FATAL ERROR: python callback ??? failed, aborting!

Comment 1 Zbigniew Jędrzejewski-Szmek 2017-01-11 22:54:15 UTC
Hm, I see two bugs here. The error in systemd-libs scriptlets got fixed in http://pkgs.fedoraproject.org/cgit/rpms/systemd.git/commit/?id=04206f627aa927dff69d881d982cbe1d91b8edc1 (#1392236).

But there's also a bug in the dnf error handling code. Reassigning.

Comment 2 Igor Gnatenko 2017-01-11 22:57:02 UTC

*** This bug has been marked as a duplicate of bug 1340507 ***


Note You need to log in before you can comment on or make changes to this bug.