Bug 141105 - Logins hang and time out, ctrl-alt-del does nothing
Summary: Logins hang and time out, ctrl-alt-del does nothing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-29 09:27 UTC by Andrew Meredith
Modified: 2015-01-04 22:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 21:40:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andrew Meredith 2004-11-29 09:27:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After an indeterminate period (from hours to days) the machine enters
a state whereby a number of things fail to operate as they should.

- Console logins (root or otherwise) hang and timeout
- Console ctrl-alt-del fails to reboot machine
- ssh with or without stop at "Entering interactive session"

Most processes that were already running continue unaffected.
Sometimes the gnome menu bars will also freeze.

The only cure is to reboot.



Version-Release number of selected component (if applicable):

kernel-2.6.9-1.681_FC3 (and earlier)
SysVinit-2.85-34
pam-0.77-65


How reproducible:
Always

Steps to Reproduce:
1. Wait
2. Try to login as root


Actual Results:  login timeout or ssh session hangs

Expected Results:  Clean login

Comment 1 Bill Nottingham 2004-11-29 17:00:25 UTC
Are there any messages in the logs?

Comment 2 Andrew Meredith 2004-11-29 17:29:27 UTC
I was actually working on this very question all afternoon. I can now
say that I can see no pattern. There is certainly nothing directly
related, no oopses or anything.

There may be a link with BIND failures leading to NFS automount
freezes on mounts that are defined by hostnames in DNS that aren't
/etc/hosts .. maybe. I mention this as a "thought in progress" only.
It is more likely that the problem is the other way round. ie The
failure causes BIND and NFS problems.


Comment 3 Bill Nottingham 2004-11-29 17:39:10 UTC
Are you using network-based auth and/or homedirs?

Comment 4 Andrew Meredith 2004-11-29 17:49:57 UTC
All the user auth is "files" based. The ordinary users are autofs'ed
off /home, but the directories are on this box.

However, the root user cannot log in and the home dir is /root on the
root filesystem, with the passwd entry being on /etc/passwd line 1.




Comment 5 Bill Nottingham 2004-11-29 20:44:06 UTC
Can you enable sysrq and get sysrq-t (or -p or -m) to see what it's
doing when it's hung?

Comment 6 Stig Hackvan 2004-12-10 04:15:55 UTC
I also get very long latency on ctrl-alt-del.  also the FC3 kernels
hang instead of rebooting... when i want to reboot, it's the reset
button (after everything's been unmounted).

--stig

Comment 7 Dave Jones 2005-07-15 20:12:02 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 8 Andrew Meredith 2005-07-15 21:40:40 UTC
This hasn't happened for a while now.

Sorry, not sure what fixed it.




Note You need to log in before you can comment on or make changes to this bug.