Bug 1411056 - CommonMark >0.6.0 breaks recommonmark
Summary: CommonMark >0.6.0 breaks recommonmark
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-recommonmark
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Julien Enselme
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1424195
TreeView+ depends on / blocked
 
Reported: 2017-01-07 22:51 UTC by Elliott Sales de Andrade
Modified: 2017-03-03 21:49 UTC (History)
1 user (show)

Fixed In Version: python-recommonmark-0.4.0-9.gitdbed1c4.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-03 21:49:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Elliott Sales de Andrade 2017-01-07 22:51:51 UTC
Description of problem:
As noted upstream [1], using recommonmark with CommonMark >0.6.0 breaks recommonmark.


Version-Release number of selected component (if applicable):
python2-recommonmark-0.4.0-7.git7ca5247.fc25.noarch
python2-CommonMark-0.7.2-2.fc25.noarch


Steps to Reproduce:
$ python
>>> import recommonmark.parser
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/recommonmark/parser.py", line 6, in <module>
    from CommonMark import DocParser, HTMLRenderer
ImportError: cannot import name DocParser


Actual results:
Import fails due to missing classes in dependencies.


Expected results:
Import should not fail.


Additional info:
[1] https://github.com/rtfd/recommonmark/issues/24

Comment 1 Fedora Update System 2017-02-22 15:34:39 UTC
python-recommonmark-0.4.0-9.gitdbed1c4.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c359b57937

Comment 2 Fedora Update System 2017-02-23 23:21:02 UTC
python-recommonmark-0.4.0-9.gitdbed1c4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c359b57937

Comment 3 Fedora Update System 2017-03-03 21:49:37 UTC
python-recommonmark-0.4.0-9.gitdbed1c4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.