Bug 1411072 - [z-stream clone - 4.0.7] UX help button for iSCSI Multipathing broken
Summary: [z-stream clone - 4.0.7] UX help button for iSCSI Multipathing broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.0.7
: ---
Assignee: Greg Sheremeta
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
Depends On: 1389549
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 06:24 UTC by rhev-integ
Modified: 2017-03-16 15:30 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1389549
Environment:
Last Closed: 2017-03-16 15:30:56 UTC
oVirt Team: UX
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC
oVirt gerrit 69272 0 None None None 2017-01-09 23:06:53 UTC
oVirt gerrit 70378 0 None None None 2017-01-17 14:06:01 UTC

Description rhev-integ 2017-01-08 06:24:20 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1389549 +++
======================================================================

Created attachment 1214751 [details]
picture of help button

When you click on DATACENTER tab ... then click on iSCSI Multipathing tab

Click ADD ...

Then click the help button - the ? (question mark) on the title bar.

It should open a new window with the RHEV documentation.  It does not.

Running Firefox 49.0 on FC23.

Other ? (question marks) in the product work on my desktop - so I think only this one is broken.

Thanks!

(Originally by Marc Skinner)

Comment 1 rhev-integ 2017-01-08 06:24:27 UTC
Thanks for reporting.

@Lucy or Tahlia, what URL should I use for this?

(Originally by Greg Sheremeta)

Comment 3 rhev-integ 2017-01-08 06:24:32 UTC
The anchor for this section (in html-single) is administration-guide/#Configuring_iSCSI_Multipathing

The closest the multi-page HTML gets is administration-guide/85-preparing-and-adding-block-storage 

I'm not certain how the mapping works now in 4.0, given the change in links and layout with the new publication system, but one of these should work. 

Leaving needinfo on Lucy in case she knows more.

(Originally by Tahlia Richardson)

Comment 4 rhev-integ 2017-01-08 06:24:37 UTC
As I understand it, although the link format has entirely changed for the Customer Portal documentation, it remains the same for the documentation packaged with the product itself.

The most recent mapping file for the Administration Portal lists the anchor for this section as:

; Data Center main tab -> iSCSI Bonds sub-tab -> New
new_iscsi_bundle=Administration_Guide/sect-Preparing_and_Adding_Block_Storage.html#Configuring_iSCSI_Multipathing

I don't have a setup with iSCSI on which to test this particular help item, but on version 4.0.5.1-0.1.el7ev of the RHV Manager, I can confirm that the anchor above matches the link in the html version of the Administration Guide available on the login page:

https://example-rhevm/ovirt-engine/docs/manual/en_US/html/Administration_Guide/sect-Preparing_and_Adding_Block_Storage.html#Configuring_iSCSI_Multipathing

(Originally by Lucy Bopf)

Comment 5 rhev-integ 2017-01-08 06:24:43 UTC
Lucy is right with the format.

Thanks for the link clarification. I'll figure out why it's failing.

(Originally by Greg Sheremeta)

Comment 6 rhev-integ 2017-01-08 06:24:47 UTC
iSCSI shouldn't have to be enabled for the help link/button to work.  It should just work, as customers will/should be able to read about the feature and how to set it up.

(Originally by Marc Skinner)

Comment 7 rhev-integ 2017-01-08 06:24:52 UTC
(In reply to marc skinner from comment #5)
> iSCSI shouldn't have to be enabled for the help link/button to work.  It
> should just work, as customers will/should be able to read about the feature
> and how to set it up.

Correct -- she was simply referring to the fact that she couldn't navigate to the correct screen to test it for me :)

(Originally by Greg Sheremeta)

Comment 8 rhev-integ 2017-01-08 06:24:56 UTC
moving to POST. Lastest build of rhevm-doc should fix this, but I need help testing it.

(Originally by Greg Sheremeta)

Comment 9 rhev-integ 2017-01-08 06:25:01 UTC
Correction on Comment 7 -- this is an engine bug. Fixed in https://gerrit.ovirt.org/#/c/69272

(Originally by Greg Sheremeta)

Comment 12 Lucie Leistnerova 2017-02-06 15:30:02 UTC
link opens new window and shows proper help for Configuring iSCSI Multipathing

verified in ovirt-engine-4.0.7-0.1.el7ev.noarch

Comment 14 errata-xmlrpc 2017-03-16 15:30:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0542.html


Note You need to log in before you can comment on or make changes to this bug.