Bug 1411085 - deploy 3rd party artifacts using wrong command to install rpms
Summary: deploy 3rd party artifacts using wrong command to install rpms
Keywords:
Status: CLOSED DUPLICATE of bug 1411084
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 10:10 UTC by Alon Dotan
Modified: 2017-03-01 21:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 21:14:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Alon Dotan 2017-01-08 10:10:30 UTC
Description of problem:
currently the deploy-artifacts.sh using "yum -y install" which will work only if images are subscribed to the RHN, would be better if adding some condition to fallback to "rpm -ivh", something like 

 yum install -y $TMP_DATA/file_data || rpm -ivh $TMP_DATA/file_data

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Emilien Macchi 2017-03-01 21:14:20 UTC

*** This bug has been marked as a duplicate of bug 1411084 ***


Note You need to log in before you can comment on or make changes to this bug.