Bug 1411098 - "Host Configuration chart" fails with "Smart Proxy not found"
Summary: "Host Configuration chart" fails with "Smart Proxy not found"
Keywords:
Status: CLOSED DUPLICATE of bug 1337483
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.2.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 11:31 UTC by Mihir Lele
Modified: 2020-06-11 13:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-08 12:58:00 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Mihir Lele 2017-01-08 11:31:03 UTC
Description of problem:

"Host Configuration chart" fails with "Smart Proxy not found" error in Satellite webui,

Version-Release number of selected component (if applicable): 6.2.3


How reproducible: Always (I was able to reproduce this issue in my test env)


Steps to Reproduce:
1. Go to Infrastructure --> Capsules --> Select the capsule --> Go to "Puppet" tab
3. Click on "Host Configuration Chart"

Actual results:  

"Host Configuration chart" fails with "Smart Proxy not found" error

Expected results:

It should display the host list

Additional info:

1. I tried this in Firefox and Chrome, and saw the same error.

2. Foreman-tail logs from my test sat are as below:

====================================================================
==> /var/log/httpd/foreman-ssl_access_ssl.log <==
192.168.122.1 - - [08/Jan/2017:06:17:29 -0500] "GET /smart_proxies/undefined HTTP/1.1" 404 2525 "https://satellite.example.com/smart_proxies/1-satellite-example-com" "Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0"


==> /var/log/foreman/production.log <==
2017-01-08 06:17:29 [app] [I] Started GET "/smart_proxies/undefined" for 192.168.122.1 at 2017-01-08 06:17:29 -0500
2017-01-08 06:17:29 [app] [I] Processing by SmartProxiesController#show as HTML
2017-01-08 06:17:29 [app] [I]   Parameters: {"id"=>"undefined"}
2017-01-08 06:17:29 [app] [I]   Rendered common/404.html.erb within layouts/application (4.5ms)
2017-01-08 06:17:29 [app] [I]   Rendered layouts/_application_content.html.erb (0.5ms)
2017-01-08 06:17:29 [app] [I]   Rendered layouts/base.html.erb (1.8ms)
2017-01-08 06:17:29 [app] [I] Completed 404 Not Found in 33ms (Views: 15.0ms | ActiveRecord: 4.3ms)

Comment 1 Tomer Brisker 2017-01-08 12:58:00 UTC

*** This bug has been marked as a duplicate of bug 1337483 ***


Note You need to log in before you can comment on or make changes to this bug.