Bug 1411107 - All UI icons are black
Summary: All UI icons are black
Keywords:
Status: CLOSED DUPLICATE of bug 1411447
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 12:33 UTC by vladimirtest
Modified: 2019-01-09 12:54 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-24 19:38:56 UTC
Type: Bug


Attachments (Terms of Use)
gnucash with black icons screenshot (7.36 KB, image/png)
2017-01-08 12:33 UTC, vladimirtest
no flags Details

Description vladimirtest 2017-01-08 12:33:38 UTC
Created attachment 1238388 [details]
gnucash with black icons screenshot

Description of problem: All UI icons are black


Version-Release number of selected component (if applicable):
$ gnucash --version
GnuCash 2.6.15
This copy was built from rev 1ef17e6+ on 2016-12-19.



How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 25 Gnome(3) with Wayland
2. sudo dnf update
3. sudo dnf install gnucash -y
4. gnucash # from command line or GUI

Actual results:
All icons are black (including start screen)

Expected results:
Normal icons

Additional info:
$ gnucash
Traceback (most recent call last):
  File "/usr/share/gnucash/python/init.py", line 5, in <module>
    import gtk
ImportError: No module named gtk
Found Finance::Quote version 1.38

Comment 1 Kevin 2017-01-15 18:44:03 UTC
Same problem here. I have used Gnucash for several years and this happened on a recent update on my AMD64 (Vishera) desktop.

GnuCash 2.6.15
This copy was built from rev 1ef17e6+ on 2016-12-19.

gnucash --debug
Found Finance::Quote version 1.38

I also deleted the .gnucash directory but that did not fix the problem - so its not related to old settings.

On my laptop, which is all Intel I get the same output but Gnucash has the icons and runs with no problem.

GnuCash 2.6.15
This copy was built from rev 1ef17e6+ on 2016-12-19.

gnucash --debug
Found Finance::Quote version 1.38

Comment 2 Bill Nottingham 2017-01-16 17:09:48 UTC
What driver are you using, and are you using Wayand?

It works for me with intel + wayland.

Comment 3 Kevin 2017-01-19 08:19:09 UTC
It doesn't say specifically but the default Gnome login option, which I assume is Wayland gives the problem. I have the option to switch to Xorg before logging in and that works normally - gnucash has all the icons and there is an image on the opening flash screen, which is not there under Wayland.

Comment 4 Bill Nottingham 2017-01-19 15:35:35 UTC
OK. The implication is then:

- AMD + Wayland: fails
- AMD + Xorg: works
- Intel + Wayland: works
- Intel + Xorg: works

Punting to kernel to be forwarded on to the AMD driver team; can be moved to Wayland if they deem appropriate.

Comment 5 Bill Nottingham 2017-01-20 03:38:02 UTC
Appears to be a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1411447 and/or https://bugzilla.redhat.com/show_bug.cgi?id=1406847

Comment 6 Laura Abbott 2017-01-24 19:38:56 UTC

*** This bug has been marked as a duplicate of bug 1411447 ***


Note You need to log in before you can comment on or make changes to this bug.