Bug 1411128 - squid randomly crashes
Summary: squid randomly crashes
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: squid
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Luboš Uhliarik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 15:35 UTC by redhat
Modified: 2017-03-30 12:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-30 12:41:28 UTC
Type: Bug


Attachments (Terms of Use)

Description redhat 2017-01-08 15:35:36 UTC
Description of problem:
The squid daemon randomly crashes


Version-Release number of selected component (if applicable):
squid-4.0.11-1.fc25.x86_64


How reproducible:
Normal usage.

Steps to Reproduce:
1.
2.
3.

Actual results:
Crashes

Expected results:
No crash

Additional info:

SELinux:
# getenforce
Permissive


Jan  8 14:27:07 manicminer systemd: Started Process Core Dump (PID 9392/UID 0).
Jan  8 14:27:07 manicminer squid[17710]: Squid Parent: (squid-1) process 17712 exited due to signal 6 with status 0
Jan  8 14:27:07 manicminer squid[17710]: Squid Parent: (squid-1) process 9395 started
Jan  8 14:27:07 manicminer systemd-coredump: Process 17712 (squid) of user 23 dumped core.#012#012Stack trace of thread 17712:#012#0  0x00007fba5e1a491f raise (libc.so.6)#012#1  0x00007fba5e1a651a abort (libc.so.6)#012#2  0x00005633e02aec24 xassert (squid)#012#3  0x00005633e02e1e20 _ZN8FwdState9completedEv (squid)#012#4  0x00005633e02e2f68 _ZN8FwdStateD1Ev (squid)#012#5  0x00005633e02e33a9 _ZN8FwdStateD0Ev (squid)#012#6  0x00005633e02e7d5d _ZN8FwdState11retryOrBailEv (squid)#012#7  0x00005633e02e821c _ZN8FwdState12serverClosedEi (squid)#012#8  0x00005633e048bb41 _ZN9AsyncCall4makeEv (squid)#012#9  0x00005633e048fe51 _ZN14AsyncCallQueue8fireNextEv (squid)#012#10 0x00005633e04901f9 _ZN14AsyncCallQueue4fireEv (squid)#012#11 0x00005633e02d24ec _ZN9EventLoop7runOnceEv (squid)#012#12 0x00005633e02d25d8 _ZN9EventLoop3runEv (squid)#012#13 0x00005633e0340f43 _Z9SquidMainiPPc (squid)#012#14 0x00005633e022f1db main (squid)#012#15 0x00007fba5e18f401 __libc_start_main (libc.so.6)#012#16 0x00005633e0239b0a _start (squid)

Comment 1 Luboš Uhliarik 2017-01-09 09:59:52 UTC
Could you please try to update to squid-4.0.17-1.fc25 a test, if squid is still failing?

Comment 2 redhat 2017-01-09 15:24:31 UTC
I have installed the package and will see if Squid continues to crash.

Comment 3 Luboš Uhliarik 2017-03-30 12:41:28 UTC
Closing this bug, since it looks like, problem was fixed by updating squid.


Note You need to log in before you can comment on or make changes to this bug.