Bug 1411147 - tlp: deprecated workaround to disable systemd-rfkill@.service
Summary: tlp: deprecated workaround to disable systemd-rfkill@.service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tlp
Version: 25
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jeremy Newton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-08 20:13 UTC by Thomas Koch
Modified: 2018-04-30 18:49 UTC (History)
4 users (show)

Fixed In Version: tlp-0.9-2.fc25 tlp-0.9-2.fc24 tlp-0.9-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 19:52:41 UTC


Attachments (Terms of Use)

Description Thomas Koch 2017-01-08 20:13:10 UTC
Description of problem:

The package creates a one line file /etc/systemd/systemd/systemd-rfkill@.service intended to disable the corresponding system service. Workaround in specfile Line 63 ff.
 
But systemd-rfkill@.service is deprecated and renamed to systemd-rfkill.service since F24.

Version-Release number of selected component (if applicable): tlp-0.9-1.fc25

How reproducible:

Steps to Reproduce:
1. Install package tlp
2. tlp-stat -s

Actual results:

Notice: systemd-rfkill@.service is not masked -- invoke "systemctl mask systemd-rfkill@.service" to correct this!

Expected results:

<no notice>

Suggested solution:

1. Rename file to systemd-rfkill.service
   or
2. Remove the workaround altogether

References:

https://github.com/linrunner/TLP/issues/219#issuecomment-259999380

Comment 1 Thomas Koch 2017-01-08 20:19:17 UTC
I didn't check the F24 package, the problem may be inherited from there.

Another suggestion: in the Debian package the service is disabled by masking it in the postinst script with

  systemctl mask system-rfkill.service

Is that feasible for Fedora too?

Comment 2 Jeremy Newton 2017-01-13 17:54:26 UTC
(In reply to Thomas Koch from comment #1)
> I didn't check the F24 package, the problem may be inherited from there.
> 
> Another suggestion: in the Debian package the service is disabled by masking
> it in the postinst script with
> 
>   systemctl mask system-rfkill.service
> 
> Is that feasible for Fedora too?

Hmm I think so, let me look into it. This is likely the correct solution for post install:

> systemctl mask systemd-rfkill

and post uninstall:

> systemctl unmask systemd-rfkill

Comment 3 Thomas Koch 2017-01-13 17:58:45 UTC
That's it.

Comment 4 Fedora Update System 2017-01-16 03:31:23 UTC
tlp-0.9-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-444f65738d

Comment 5 Fedora Update System 2017-01-16 03:31:30 UTC
tlp-0.9-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c68b1957

Comment 6 Jeremy Newton 2017-01-16 03:35:00 UTC
I tried pushing the fix to epel7, but it didn't take. I'll push it as soon as I figure out what's up.

Comment 7 Fedora Update System 2017-01-16 12:56:35 UTC
tlp-0.9-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-9e15663376

Comment 8 Fedora Update System 2017-01-16 21:22:03 UTC
tlp-0.9-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-9e15663376

Comment 9 Fedora Update System 2017-01-16 22:22:43 UTC
tlp-0.9-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-60c68b1957

Comment 10 Fedora Update System 2017-01-16 22:23:24 UTC
tlp-0.9-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-444f65738d

Comment 11 Thomas Koch 2017-01-17 05:44:11 UTC
Update works as expected (fc25). Thank you!

Comment 12 Jeremy Newton 2017-01-17 15:17:25 UTC
(In reply to Thomas Koch from comment #11)
> Update works as expected (fc25). Thank you!

No problem, thank you for reporting the issue.

Comment 13 Fedora Update System 2017-01-17 19:52:41 UTC
tlp-0.9-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2017-01-25 00:21:09 UTC
tlp-0.9-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2017-01-31 18:18:11 UTC
tlp-0.9-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 bugreports2005 2018-04-30 10:04:57 UTC
As of RHEL 7.5 there seems to be /usr/lib/systemd/system/systemd-rfkill@.service instead of systemd-rfkill.service, so perhaps the inclusion of this in EPEL7 is breaking instead of fixing things.

Comment 17 Jeremy Newton 2018-04-30 18:49:45 UTC
Hmm, this seems to be the case as well for my CentOS 7.4 system, but I haven't noticed anything wrong compared to Fedora. Running "tlp-stat -s" as root seems normal to me. Does this exhibit any bad behavior for you?

If so, you can try using the "systemctl mask" or "systemctl unmask" commands as root, similar to what's described above, and let me know what works for you?


Note You need to log in before you can comment on or make changes to this bug.