Bug 1411209 - Readdir-ahead: Support multithreaded readdirp
Summary: Readdir-ahead: Support multithreaded readdirp
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: GlusterFS
Classification: Community
Component: read-ahead
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 06:06 UTC by Poornima G
Modified: 2018-11-19 04:44 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 04:44:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2017-01-09 06:06:28 UTC
Description of problem:
Currently the way readdirp is designed, there can be no two parallel readdir issued on the same fd(because of the fd ctx structure and the way it is built and used). But it is not impossible to issue two readdirps on the same fd. Hence fix this use case.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Poornima G 2018-11-19 04:44:04 UTC
This is not really a priority now, hence closing this bug until a strong need for the same arises.


Note You need to log in before you can comment on or make changes to this bug.