Bug 1411217 - Printing to HP LaserJet M402dn results in stopped jobs
Summary: Printing to HP LaserJet M402dn results in stopped jobs
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Dohnal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 06:56 UTC by Aram Agajanian
Modified: 2017-01-13 09:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 09:29:48 UTC
Type: Bug


Attachments (Terms of Use)
Output of the command "journalctl -u cups -e" with LogLevel debug in cupsd.conf (102.85 KB, text/plain)
2017-01-09 06:56 UTC, Aram Agajanian
no flags Details
Output of hp-check command (15.08 KB, text/plain)
2017-01-11 04:14 UTC, Aram Agajanian
no flags Details

Description Aram Agajanian 2017-01-09 06:56:29 UTC
Created attachment 1238572 [details]
Output of the command "journalctl -u cups -e" with LogLevel debug in cupsd.conf

Description of problem:
I just set up my HP LaserJet M402dn printer using the Add a New Printer tool.  I entered the IP address of the printer and then selected the option for HP-LaserJet-M402dn.  There is then a notification that Additional Printer Drivers are required but the Software program can't find any.  Note that I was able to use this printer in past versions of Fedora without installing additional drivers.

I looked in the logs and found the following:

Jan 09 01:45:53 pc01 cupsd[26681]: Set job-printer-state-message to "Processing page 1...", current level=INFO
Jan 09 01:45:53 pc01 hpcups[26917]: prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1
Jan 09 01:45:53 pc01 cupsd[26681]: prnt/hpcups/Hbpl1.cpp 52: Hbpl1 constructor : m_szLanguage = HBPL1STATE: +hplip.plugin-error
Jan 09 01:45:53 pc01 cupsd[26681]: prnt/hpcups/HPCupsFilter.cpp 487: m_Job initialization failed with error = 48
Jan 09 01:45:53 pc01 cupsd[26681]: PID 26917 (/usr/lib/cups/filter/hpcups) stopped with status 1.
Jan 09 01:45:53 pc01 cupsd[26681]: Hint: Try setting the LogLevel to "debug" to find out more.


Version-Release number of selected component (if applicable):
cups-filesystem-2.2.0-4.fc25.noarch
cups-pk-helper-0.2.6-1.fc24.x86_64
cups-libs-2.2.0-4.fc25.x86_64
cups-2.2.0-4.fc25.x86_64
cups-filters-libs-1.10.0-3.fc25.x86_64
cups-client-2.2.0-4.fc25.x86_64
cups-filters-1.10.0-3.fc25.x86_64
hplip-3.16.11-3.fc25.x86_64


How reproducible:
Happens every time

Steps to Reproduce:
1. Add HP LaserJet M402dn printer using Add a New Printer tool
2. Print to the new printer

Actual results:
The print job has a status of Stopped and doesn't print out.

Expected results:
The print job should be printed by the printer.

Comment 1 Zdenek Dohnal 2017-01-09 07:51:13 UTC
Hi Aram,

thank you for contacting us. From that log I think the problem is in hplip plugin, which is curious if that printer does not need additional plugin. Would you mind sending output of 'hp-check' command? And can you try reinstall that printer with 'hp-setup -i' and 'hp-plugin' if it helps?

Comment 2 Aram Agajanian 2017-01-11 04:14:52 UTC
Created attachment 1239306 [details]
Output of hp-check command

Comment 3 Aram Agajanian 2017-01-11 04:23:15 UTC
(In reply to Zdenek Dohnal from comment #1)
> And can you try
> reinstall that printer with 'hp-setup -i' and 'hp-plugin' if it helps?

I ran the the 'hp-setup -i' command.  It seems to have worked well.  The test page looks good.  I have also been able to print from evince.

Let me know if there is something else that I should test involving 'hp-plugin'.

Comment 4 Zdenek Dohnal 2017-01-11 09:32:31 UTC
If I understand comment #3 correctly, printer works after "hp-setup -i"? So would you mind if I close this bug or do you have any other issues?

Comment 5 Aram Agajanian 2017-01-13 05:34:00 UTC
Closing this bug is fine with me.  Thank you for the help!

Comment 6 Zdenek Dohnal 2017-01-13 09:29:48 UTC
You are welcome, Aram. Have a nice day.


Note You need to log in before you can comment on or make changes to this bug.