Bug 1411228 - remove-brick status shows 0 rebalanced files
Summary: remove-brick status shows 0 rebalanced files
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: mainline
Hardware: x86_64
OS: FreeBSD
unspecified
medium
Target Milestone: ---
Assignee: Xavi Hernandez
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1373618 1424973 1424974
TreeView+ depends on / blocked
 
Reported: 2017-01-09 08:10 UTC by Xavi Hernandez
Modified: 2017-05-30 18:38 UTC (History)
4 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1373618
: 1424973 1424974 (view as bug list)
Environment:
Last Closed: 2017-05-30 18:38:06 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1176011 0 high CLOSED Client sees duplicated files 2021-02-22 00:41:40 UTC

Internal Links: 1176011

Description Xavi Hernandez 2017-01-09 08:10:47 UTC
+++ This bug was initially created as a clone of Bug #1373618 +++

Description of problem:  With a 2-brick distributed volume, performing a remove-brick start successfully transfers files, but remove-brick status shows 0 rebalanced-files.


Version-Release number of selected component (if applicable): CentOS 6 and FreeBSD 10 3.7.13


How reproducible: easily


Steps to Reproduce:
[root@colossus bricks]# gluster volume create removebricktest 192.168.110.1:/tank/bricks/rbt 192.168.110.2:/ftp/bricks/rbt
volume create: removebricktest: success: please start the volume to access data
[root@colossus bricks]# gluster volume start removebricktest
volume start: removebricktest: success
[root@colossus bricks]# mount -t glusterfs 192.168.110.2:/removebricktest /mnt/test
[root@colossus bricks]# cd /mnt/test
[root@colossus test]# ls
[root@colossus test]# touch file{1..100}
[root@colossus test]# ls file*| wc -l
100
[root@colossus test]# ls /ftp/bricks/rbt/file*| wc -l
28

[root@colossus2 ~]# ls /tank/bricks/rbt/file*| wc -l
      72

[root@colossus test]# gluster volume remove-brick removebricktest 192.168.110.2:/ftp/bricks/rbt start
volume remove-brick start: success
ID: c88553ba-7372-4706-bafb-b1b0e4aea9ba
[root@colossus test]# ls /ftp/bricks/rbt/file*| wc -l
28

[root@colossus2 ~]# ls /tank/bricks/rbt/file*| wc -l
     100

[root@colossus test]# gluster volume remove-brick removebricktest 192.168.110.2:/ftp/bricks/rbt status
                                    Node Rebalanced-files          size       scanned      failures       skipped               status  run time in h:m:s
                               ---------      -----------   -----------   -----------   -----------   -----------         ------------     --------------
                               localhost                0        0Bytes            28             0             0            completed        0:0:0



Actual results:
0 rebalanced-files


Expected results:
28 rebalanced-files

Additional info:

Comment 1 Worker Ant 2017-01-16 10:41:44 UTC
REVIEW: http://review.gluster.org/16417 (posix: Fix creation of files with S_ISVTX on FreeBSD) posted (#1) for review on master by Xavier Hernandez (xhernandez@datalab.es)

Comment 2 Worker Ant 2017-02-18 17:22:33 UTC
COMMIT: https://review.gluster.org/16417 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 621fedf8aeb3e972db33b3eefa6cbdbef104d6a6
Author: Xavier Hernandez <xhernandez@datalab.es>
Date:   Tue Jan 10 17:21:56 2017 +0100

    posix: Fix creation of files with S_ISVTX on FreeBSD
    
    On FreeBSD the S_ISVTX flag is completely ignored when creating a
    regular file. Since gluster needs to create files with this flag set,
    specialy for DHT link files, it's necessary to force the flag.
    
    This fix does this by calling fchmod() after creating a file that
    must have this flag set.
    
    Change-Id: I51eecfe4642974df6106b9084a0b144835a4997a
    BUG: 1411228
    Signed-off-by: Xavier Hernandez <xhernandez@datalab.es>
    Reviewed-on: https://review.gluster.org/16417
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>

Comment 3 Shyamsundar 2017-05-30 18:38:06 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.