Bug 1411236 - Automatic codec installer missing org.freedesktop.PackageKit
Summary: Automatic codec installer missing org.freedesktop.PackageKit
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: parole
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1440331
TreeView+ depends on / blocked
 
Reported: 2017-01-09 08:47 UTC by Sam Tygier
Modified: 2017-12-12 10:10 UTC (History)
8 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-12-12 10:10:07 UTC


Attachments (Terms of Use)

Description Sam Tygier 2017-01-09 08:47:14 UTC
On a fresh F25 Mate install opening a video file gives the Parole media player. If the required codec is not available a dialog is shown

"Aditional software is required
Parole need a H.264 decoder to play this file. It can be installed automatically.
[Don't Install] [Install]"

If I click install I get:

** Message: PackageKit: Codec nice name: H.264 (High Profile) decoder
** Message: PackageKit: ignoring field named level
** Message: PackageKit: ignoring field named profile
** Message: PackageKit: structure: gstreamer1(decoder-video/x-h264)()(64bit)
** Message: PackageKit: Did not install codec: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.PackageKit was not provided by any .service files

It would be great if the auto codec install worked on Fedora MATE. Otherwise if that can't be done, it should not be offered. Perhaps the message could say "Please install gnome-software in order to use auto codec install" (assuming that would work).

Comment 1 Kevin Fenzi 2017-01-09 20:55:43 UTC
Well, in order for this to work, PackageKit needs to be installed. 

I guess it's not on the mate spin?

If you install PackageKit does it start working?

Comment 2 Sam Tygier 2017-01-09 23:59:23 UTC
I tried installing PackageKit but that does not seem to be enough on its own (I get the same error). If I install gnome-software, then the install button triggers a notification that launches gnome-software and finds the package. But gnome-software does not seem to be fully working (it does not show any packages on the front page), though it did seem to set up the cisco repo and install the openh264 package. Parole still wont play the file I have. Those are somewhat separate issues though.

I guess the good solutions to the original bug are:
1) Ship enough of PackageKit/gnome-software in the MATE spin
or
2) Make parole inform you what is needed for auto code install

Comment 3 Mukundan Ragavan 2017-01-10 02:15:03 UTC
I am not sure if parole can inform about the packages needed.

This would have to handled by packagekit I would imagine?

Comment 4 Wolfgang Ulbrich 2017-01-10 07:55:52 UTC
A subpackage of packagekit is needed to get this working, but i forgot which one :-)
Personal i simply install gstreamer1-libav, gstreamer1-plugins-bad-free and gstreamer1-plugins-bad-freeworld to play videos, but all this is from rpmfusion and nonfree.
In general the Mate spin use yumex-dnf as package-manager and we don't need packagekit or gnome-software.
If parole need this for installing nonfree software than it is paroles job to add all dependencies.
Btw. Mate desktop is marked as an 'incompatible desktop' in a gsettings key by gnome-software by their developer from redhat.
Sadly those guy ignore that we added appdata infos to our apps before he marked Mate as 'incompatible desktop'.
Sorry, i do not add something to Mate spin which do not want to work with MATE.

Comment 5 Fedora Admin XMLRPC Client 2017-01-29 10:31:02 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 6 AsciiWolf 2017-10-24 08:56:43 UTC
Any news regarding this issue?

Comment 7 Mukundan Ragavan 2017-10-25 01:59:08 UTC
The package we need to install for parole to suggest codecs would be PackageKit-gstreamer-plugin I think.


However, xfce spin does not ship packagekit by default (nor do I want to change it now). I would if I could add it as Suggests: for parole.

Kevin, Wolfgang - what do you guys think?

Comment 8 Fedora End Of Life 2017-11-16 18:34:52 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 9 Fedora End Of Life 2017-12-12 10:10:07 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.