Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1411266 - Save button is disabled when single command is removed from command editor
Summary: Save button is disabled when single command is removed from command editor
Keywords:
Status: CLOSED DUPLICATE of bug 1411258
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 10:01 UTC by XiaochuanWang
Modified: 2017-01-09 14:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-09 14:13:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XiaochuanWang 2017-01-09 10:01:35 UTC
Description of problem:
After successfully added multiple independent commands, remove one command but the Save button is disabled. The button is only enabled when user removed multiple independent commands.

Version-Release number of selected component (if applicable):
openshift v3.4.0.39

How reproducible:
Always

Steps to Reproduce:
1. oc run dc --image=aosqe/hello-openshift
2. From web console, go to dc edit page "https://xxx:8443/console/project/myproject/edit/dc/dc".
Click "advanced strategy options." and add 2 commands "echo test 1" and "echo test 2" in Pre Lifecycle Hook, hit "Add" in the right of the input box and hit "Save"
3. Go to dc edit page again, click "advanced strategy options."
Remove one command and check "Save" button
4. Remove another command and check "Save" button

Actual results:
Step 3. Save button is disabled.
Step 4. Save button is enabled.

Expected results:
Step 3. Save button should be enabled.

Additional info:
After user edited one command in step 3, the Save button is enabled, then user removed the edited command, the button is still enabled.
This is a common issue, also reproduced in dc health check edit page.

Comment 1 Samuel Padgett 2017-01-09 14:13:06 UTC
Same underlying cause as https://bugzilla.redhat.com/show_bug.cgi?id=1411258

*** This bug has been marked as a duplicate of bug 1411258 ***


Note You need to log in before you can comment on or make changes to this bug.