Bug 1411288 - [GSS](6.4.z) Deadlock in BasicAction when jboss remoting and JTA is used
Summary: [GSS](6.4.z) Deadlock in BasicAction when jboss remoting and JTA is used
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: EJB
Version: 6.4.7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.4.13
Assignee: Fedor Gavrilov
QA Contact: Jan Martiska
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 11:10 UTC by Tom Ross
Modified: 2020-04-15 15:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-16 15:45:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Ross 2017-01-09 11:10:03 UTC
At EJBRemoteTransactionPropagatingInterceptor, a transaction that has been already open at current server could be ignored, thus causing the transaction to be reimported, resulting in the double diamond problem.

To reproduce you need a reinvocation at a server that was already participating in the transaction, as the scenario below for example:
    server1 -> server2 -> server1

Comment 2 Brad Maxwell 2017-03-16 15:45:53 UTC
Closing as this was fixed in EAP 6.4 CP13, so this is a duplicate of another one possibly: https://bugzilla.redhat.com/show_bug.cgi?id=1378396


Note You need to log in before you can comment on or make changes to this bug.