Bug 1411290 - bad performance of snmpd while walk-through ipv6IfDescr if interface index too large
Summary: bad performance of snmpd while walk-through ipv6IfDescr if interface index to...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: net-snmp
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Josef Ridky
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 1437508 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 11:14 UTC by Dalibor Pospíšil
Modified: 2019-12-10 14:26 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1411306 (view as bug list)
Environment:
Last Closed: 2019-12-10 14:26:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
abrt logs including coredump (1.02 MB, application/x-bzip)
2017-01-09 11:14 UTC, Dalibor Pospíšil
no flags Details

Description Dalibor Pospíšil 2017-01-09 11:14:17 UTC
Created attachment 1238664 [details]
abrt logs including coredump

Description of problem:
snmpd eatch too much CPU and RAM while processing ipv6IfDescr part of the tree if interface index is too large. It eats more resources as index is larger. This leads to timeout snmpwalk request, the timeout needs to be extend to get the data.

I also get core-dumps at some point, see attachment.

Version-Release number of selected component (if applicable):
net-snmp-5.7.2-24.el7_2.1

How reproducible:
100%

Steps to Reproduce:
1. set manage ifindex to be big enough, e.g. 268435448
2. start snmpd
3. issue snmpbulkwalk -t 15 localhost ipv6IfDescr

Actual results:
snmpbulkwalk times out and snmpd eats up system resources and coredumps

Expected results:
snmpd behaves nicly to system resources and snmpbulkwalk gets all the data

Additional info:

Comment 1 Josef Ridky 2019-01-10 12:08:04 UTC
*** Bug 1437508 has been marked as a duplicate of this bug. ***

Comment 2 Josef Ridky 2019-12-10 14:26:44 UTC
Red Hat Enterprise Linux version 7 is entering the Maintaining phase 1 of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

Closing as WONTFIX.


Note You need to log in before you can comment on or make changes to this bug.