Bug 1411294 - Update of DVR router to be HA fails with 'HAmodeUpdateOfDvrNotSupported'
Summary: Update of DVR router to be HA fails with 'HAmodeUpdateOfDvrNotSupported'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: anil venkata
QA Contact: GenadiC
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 11:37 UTC by GenadiC
Modified: 2017-05-17 19:54 UTC (History)
8 users (show)

Fixed In Version: openstack-neutron-10.0.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:54:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
Launchpad 1654991 None None None 2017-03-22 05:15:34 UTC

Description GenadiC 2017-01-09 11:37:26 UTC
Description of problem:
Though the creation of DVR HA router succeeds, it's impossible to "update" router to be DVR and HA
Trying to update DVR router to be HA you get:
 501-{u'NotImplementedError': {u'message': u'', u'type': u'HAmodeUpdateOfDvrNotSupported', u'detail': u''}}
Neutron server returns request_ids: ['req-d0727fec-3112-4d2b-9f67-d23cf78e4c5f']

Version-Release number of selected component (if applicable):
openstack-neutron-9.1.0-8.el7ost.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create Router non-HA and DVR
2. Try to update router to be HA and DVR (ha=True)
3.

Actual results:
An update fails with 'HAmodeUpdateOfDvrNotSupported'

Expected results:
Update should succeed and you should get the DVR HA router

Additional info:

Comment 2 Assaf Muller 2017-01-31 16:54:12 UTC
Merged upstream, waiting for M3 OSP build to flip to MODIFIED.

Comment 4 GenadiC 2017-03-21 13:34:15 UTC
I need the correct launchpad tracker as the provided one is incorrect
As well I need the build ID in order to do the code verification for this bug

Comment 7 errata-xmlrpc 2017-05-17 19:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.