Bug 1411296 - openshift-jvm Camel console Debug view empty "Breakpoint suspended at" slideout opened, cannot be closed
Summary: openshift-jvm Camel console Debug view empty "Breakpoint suspended at" slideo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Alexandre Kieling
QA Contact: Peng Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 11:53 UTC by Marek Schmidt
Modified: 2017-07-24 14:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: slideout window is fixed and stays above the camel route diagram Consequence: when the diagram is large, the slideout window cover parts of it Fix: make the slideout window show up only when we stop at a breakpoint Result: the slideout window doesn't cover the diagram all the time as before
Clone Of:
Environment:
Last Closed: 2017-04-12 19:08:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
an empty "Breakpoint suspended at" slideout is opened and cannot be closed (118.34 KB, image/png)
2017-01-09 11:53 UTC, Marek Schmidt
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0884 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.5 RPM Release Advisory 2017-04-12 22:50:07 UTC

Description Marek Schmidt 2017-01-09 11:53:26 UTC
Created attachment 1238716 [details]
an empty "Breakpoint suspended at" slideout is opened and cannot be closed

Description of problem:

In the openshift-jvm console on a Camel application, opening the Debug view makes the "Breakpoint suspended at" slideout open even if no breakpoint is suspended yet, and cannot be closed. 

This slideout hovers above the camel route diagram, so it prevents selecting some camel route elements.

Version-Release number of selected component (if applicable):

atomic-openshift 3.4.0.38-1.git.0.8561cba.el7

openshift-jvm
Version: 1.0.57
Commit ID: 80441ef1187ce1807e5ce5ea994d869a2c272fcc

How reproducible:
Always

Steps to Reproduce:
1. Deploy a version of karaf2-camel-amq FIS quickstart, 

oc create -f https://raw.githubusercontent.com/maschmid/karaf2-camel-amq/bz1393711/karaf2-camel-amq-template.json
oc process s2i-karaf2-camel-amq | oc create -f 

and wait for the build and deployment

2. open the openshift console and find the s2i-karaf2-camel-amq-1-xxxx pod  
3. open the "Java Console" on the pod
4. Open the camel context, 'Routes' folder
5. Switch to 'Debug'
6. Start debugging

Actual results:

An "Breakpoint suspended at" slideout is openend, covering part of the camel route diagram, this slideout cannot be closed.

(see attachment for screenshot)

Expected results:

Full camel route diagram should be visible, the "Breakpoint suspended at" slideout  should only be opened when the actual breakpoint is suspended, and it should be able to close this slideout.

Additional info:

Looks the same in Firefox and Chrome

Comment 1 Alexandre Kieling 2017-01-16 17:38:58 UTC
Fixed on hawtio/openshift-jvm v1.1.2
The slideout only shows up when we stop at a breakpoint and disappears when we continue execution.

Comment 2 Jessica Forrester 2017-01-16 19:22:14 UTC
Fix is merging into the console with
https://github.com/openshift/origin-web-console/pull/1122

QE: since this bumps openshift-jvm to 1.1.2 this brings in a number of updated dependencies like angular, it would be good to get in a regression of the jvm console after this is in a 1.5 build

Comment 3 Troy Dawson 2017-01-20 22:52:23 UTC
This has been merged into ocp and is in OCP v3.5.0.7 or newer.

Comment 4 Peng Li 2017-01-22 09:17:22 UTC
verified with openshift v3.5.0.7+390ef18, attach the screen-shot.

Comment 7 errata-xmlrpc 2017-04-12 19:08:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0884


Note You need to log in before you can comment on or make changes to this bug.