This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 141130 - IT8212 IDE Controller driver breaks boot on > 2.6.9 FC2 and FC3
IT8212 IDE Controller driver breaks boot on > 2.6.9 FC2 and FC3
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 10:33 EST by Peter Backlund
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 18:20:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Backlund 2004-11-29 10:33:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041114 Firefox/1.0

Description of problem:
Kernels after 2.6.9-1.667 are built with CONFIG_BLK_DEV_IT8212=y,
which includes a new driver for the ITE 8212 IDE/RAID controller
chipsets from the -ac patchset. I have one of these controllers (the
non-raid variant), and both the most recent FC2 and FC3 errata kernels
refuse to boot (kernel panic - no init found). However, I've built a
stand-alone module against 2.6.8-1.521 using the source from one of
the -ac patches  (not sure which one, the version of the driver is
'Version 0.03se  October 2004'), which works fine, both inside the
initrd and if I insert it after booting.

lspci -vv:

00:0e.0 Unknown mass storage controller: Integrated Technology
Express, Inc. IT/ITE8212 Dual channel ATA RAID controller (PCI version
seems to be IT8212, embedded seems (rev 11)
        Subsystem: Integrated Technology Express, Inc.: Unknown device
0001
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0 (2000ns min, 2000ns max)
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at b400
        Region 1: I/O ports at b000 [size=4]
        Region 2: I/O ports at a800 [size=8]
        Region 3: I/O ports at a400 [size=4]
        Region 4: I/O ports at a000 [size=16]
        Capabilities: [80] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-


I have two discs attached to the motherboard controller, hda and hdc.
FC2 / is on hdc2, FC3 / is on hda8. On the ITE controller I have two
cd-roms, hde and hdg. A longshot guess would be that the numbering of
the IDE devices got mixed up somewhere between my good version and the
errata/FC3 kernels? 

Version-Release number of selected component (if applicable):
2.6.9-1.6_FC2

How reproducible:
Always

Steps to Reproduce:
1. Install FC3 with vanilla kernel, or FC2 with latest errata 
2. Boot 
3.
    

Actual Results:  Boot failed, kernel panic - no init found

Expected Results:  Should boot fine

Additional info:

This bug should probably be assigned to Alan Cox, since he's written
the driver in question.
Comment 1 Dave Jones 2004-11-29 14:05:19 EST
Alan, sound familiar ? Fixed in latest -ac ?
Comment 2 Alan Cox 2004-11-30 14:05:19 EST
Never seen this happening and I run FC3/FC2 on IT8212 as you can
imagine. The newer it8212 code has fixed various oddments but there is
nothing IDE fixed that would impact this since the pci/generic fix to
sort out stealing SATA adapters.

I can't see it being ordering because the newer initrd stuff we have
is all based on LABELs so it would find the root fs wherever it hid
Comment 3 Peter Backlund 2004-12-04 14:48:36 EST
Actually, it turns out my guess was right. The onboard IDE channels are now
hd[e,f,g,h] and the ITE board channels are hd[a,b,c,d]. This broke grub and
fstab, since they both use /dev/hdX notation (custom modification of mine though).

It should work fine if grub/fstab are using labels. Remind me again, how do I
edit the partition labels? I can't find anything relevant in fdisk.
Comment 4 Alan Cox 2004-12-04 18:20:56 EST
tune2fs I think.  You may also need to reinstall grub to get the boot blocks right.

Will close this now we know it isnt a kernel bug per se.

Note You need to log in before you can comment on or make changes to this bug.