Bug 1411315 - Oops message displayed with an exclamation mark once user logs into cockpit UI
Summary: Oops message displayed with an exclamation mark once user logs into cockpit UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Generic
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.1
: 0.10.7-0.0.10
Assignee: Ryan Barry
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 12:47 UTC by RamaKasturi
Modified: 2017-04-21 09:40 UTC (History)
13 users (show)

Fixed In Version: cockpit-ovirt-0.10.7-0.0.7.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:40:07 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
cshao: testing_ack+


Attachments (Terms of Use)
attaching screenshot for the oops message (110.00 KB, image/png)
2017-01-09 12:47 UTC, RamaKasturi
no flags Details
Attaching screenshot for console output (30.65 KB, image/png)
2017-01-11 14:02 UTC, RamaKasturi
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 70161 0 'None' MERGED dashboard: don't require bundle.js 2021-02-05 08:46:15 UTC
oVirt gerrit 72051 0 'None' MERGED dashboard: don't require bundle.js 2021-02-05 08:46:15 UTC

Description RamaKasturi 2017-01-09 12:47:21 UTC
Created attachment 1238757 [details]
attaching screenshot for the oops message

Description of problem:
Once user logs into cockpit there is a oops message displayed on the top right corner and clicking on that user gets an error message which says "Unexpected error". Cockpit had an unexpected internal error.

You can try restarting Cockpit by pressing refresh in your browser. The javascript console contains details about this error (Ctrl-Shift-J in most browsers).

Version-Release number of selected component (if applicable):
cockpit-ws-122-3.el7.x86_64
cockpit-storaged-122-3.el7.noarch
cockpit-shell-122-3.el7.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.2.el7ev.noarch
cockpit-bridge-122-3.el7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL7.3 system
2. Now install cockpit-ovirt-dashboard
3. Once installation finishes login to cockpit UI

Actual results:
There is a oops message displayed on the top right corner once user logs into cockpit and clicking on that displays the error attached in the screenshot.

Expected results:
No error message should be displayed.

Additional info:

Comment 1 Ryan Barry 2017-01-11 13:10:43 UTC
Can you please grab the console output from Firefox (F12 should be ok)?

Comment 2 RamaKasturi 2017-01-11 14:02:30 UTC
Created attachment 1239452 [details]
Attaching screenshot for console output

Comment 3 Ryan Barry 2017-01-12 04:19:05 UTC
Unfortunately, the console log doesn't have anything useful.

Also, I can't reproduce this. Can you please provide detailed steps to reproduce, as well as a test environment (if HC is required to reproduce -- I don't have room for a gluster test environment in my lab)?

Comment 4 RamaKasturi 2017-01-12 13:45:51 UTC
Below are the steps to reproduce this error:

1) Install cockpit-ovirt-dashboard on RHEL7.3 system.'yum install http://download.eng.bos.redhat.com/brewroot/packages/cockpit-ovirt/0.10.7/0.0.2.el7ev/noarch/cockpit-ovirt-dashboard-0.10.7-0.0.2.el7ev.noarch.rpm'

2) add the port 9090 by running the command 'firewall-cmd --add-port=9090/tcp'

3) start cockpit service by running the command 'systemctl start cockpit'

4) Login to cockpit UI and click on virtualization tab.

5) OOPS on right top most corner can be seen.

I will email you the details of my test environment.

Comment 5 Ryan Barry 2017-01-12 16:30:07 UTC
This appears to be very low priority, and should not block testing at all.

I'm investigating a patch, but this is cosmetic only.

Comment 6 Wei Wang 2017-02-08 06:57:25 UTC
Test Version
RHEL-7.3-20161019.0-Server-x86_64-dvd1.iso
cockpit-ws-126-1.el7.x86_64
cockpit-bridge-126-1.el7.x86_64
cockpit-ovirt-dashboard-0.10.7-0.0.2.el7ev.noarch

Steps:
1. Install RHEL7.3 system
2. Install cockpit-ovirt-dashboard
3. Login to cockpit UI and click on virtualization tab.

Results:
Oops message on right top most corner can be seen.

QE can reproduce this bug.

Comment 7 Wei Wang 2017-02-27 07:40:13 UTC
Test Version
RHEL-7.3-20161019.0-Server-x86_64-dvd1.iso
cockpit-ws-126-1.el7.x86_64
cockpit-bridge-126-1.el7.x86_64
cockpit-ovirt-dashboard-0.10.7-0.0.7.el7ev.noarch


Steps:
1. Install RHEL7.3 system
2. Install cockpit-ovirt-dashboard
3. Login to cockpit UI and click on virtualization tab.

Results:
No error message is displayed on right top corner.

The bug cannot be reproduced, change the status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.