Bug 1411318 - Fail to deploy host with spice/qxl
Summary: Fail to deploy host with spice/qxl
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Plugins.General
Version: 2.1.0
Hardware: x86_64
OS: Unspecified
medium
high
Target Milestone: ovirt-4.1.0-rc
: 2.1.0
Assignee: Simone Tiraboschi
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 13:06 UTC by hlmasterchief93
Modified: 2017-05-11 09:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 14:52:46 UTC
oVirt Team: Integration
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
fail log (412.33 KB, text/plain)
2017-01-09 13:09 UTC, hlmasterchief93
no flags Details
success log (474.47 KB, text/plain)
2017-01-09 13:09 UTC, hlmasterchief93
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 69900 0 master MERGED virt: fixing the graphics device for spice console 2017-01-10 15:23:47 UTC
oVirt gerrit 69907 0 ovirt-hosted-engine-setup-2.1 MERGED virt: fixing the graphics device for spice console 2017-01-10 15:27:38 UTC

Description hlmasterchief93 2017-01-09 13:06:41 UTC
Description of problem:
Choosing "spice" console type when running hosted-engine --deploy cause the deploy fail with this message {'status': {'message': u'Error creating the requested VM', 'code': 9}}

Switch to "vnc" and deploy successfully

Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-2.1.0-0.0.master.20161221071740.git46cacd3.fc24.noarch
ovirt-release41-pre-4.1.0-0.6.beta2.20161221025826.gitc487776.el7.centos.noarch
fedora 24 server
kernel 4.8.15-200.fc24.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 24
2. Upgrade
3. Install ovirt-release41-pre
4. Install ovirt-hosted-engine-setup
5. Install ovirt-engine-appliance-4.1-20161222.1.el7.centos.noarch.rpm
6. Install python2-dnf (https://bugzilla.redhat.com/show_bug.cgi?id=1358339)
7. Run hosted-engine --deploy and choose "spice" console type

Actual results:
[ ERROR ] Failed to execute stage 'Closing up': Cannot create the VM: Error creating the requested VM

Expected results:
[ INFO  ] Hosted Engine successfully deployed

Additional info:
Someone has the same problem with beta 1 https://www.mail-archive.com/users@ovirt.org/msg37495.html

Comment 1 hlmasterchief93 2017-01-09 13:09:00 UTC
Created attachment 1238770 [details]
fail log

Comment 2 hlmasterchief93 2017-01-09 13:09:49 UTC
Created attachment 1238771 [details]
success log

Comment 3 Nikolai Sednev 2017-02-14 17:33:55 UTC
Works for me on these components on host:
sanlock-3.4.0-1.el7.x86_64
ovirt-node-ng-nodectl-4.1.0-0.20170104.1.el7.noarch
qemu-kvm-rhev-2.6.0-28.el7_3.3.x86_64
vdsm-4.19.4-1.el7ev.x86_64
ovirt-imageio-common-1.0.0-0.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
ovirt-setup-lib-1.1.0-1.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
mom-0.5.8-1.el7ev.noarch
ovirt-imageio-daemon-1.0.0-0.el7ev.noarch
ovirt-hosted-engine-ha-2.1.0.1-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.0.1-1.el7ev.noarch
ovirt-vmconsole-1.0.4-1.el7ev.noarch
libvirt-client-2.0.0-10.el7_3.4.x86_64
ovirt-host-deploy-1.6.0-1.el7ev.noarch
Linux version 3.10.0-514.6.1.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Sat Dec 10 11:15:38 EST 2016
Linux localhost.localdomain 3.10.0-514.6.1.el7.x86_64 #1 SMP Sat Dec 10 11:15:38 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux release 7.3

Engine:
rhevm-setup-plugins-4.1.0-1.el7ev.noarch
rhevm-dependencies-4.1.0-1.el7ev.noarch
rhevm-doc-4.1.0-2.el7ev.noarch
rhev-guest-tools-iso-4.1-3.el7ev.noarch
rhevm-4.1.0.3-0.1.el7.noarch
rhevm-branding-rhev-4.1.0-0.el7ev.noarch
Linux version 3.10.0-514.6.1.el7.x86_64 (mockbuild@x86-030.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-11) (GCC) ) #1 SMP Sat Dec 10 11:15:38 EST 2016
Linux 3.10.0-514.6.1.el7.x86_64 #1 SMP Sat Dec 10 11:15:38 EST 2016 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.3 (Maipo)

Successfully deployed HE over NFS, using Spice.


Note You need to log in before you can comment on or make changes to this bug.