Bug 1411320 - Upgrade miq_postgres_upgrade.sh script fails upgrading from CF4.1 to CF4.2.
Summary: Upgrade miq_postgres_upgrade.sh script fails upgrading from CF4.1 to CF4.2.
Keywords:
Status: CLOSED DUPLICATE of bug 1387672
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.1
Assignee: Nick Carboni
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 13:12 UTC by Raul Mahiques
Modified: 2017-01-30 12:33 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 20:05:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Raul Mahiques 2017-01-09 13:12:03 UTC
Description of problem:
Following the migration guide:
https://access.redhat.com/documentation/en/red-hat-cloudforms/4.2/single/migrating-to-red-hat-cloudforms-42/
to migrate from 4.1 to 4.2 at the step 1.4.1.7 the script fails:

line 43: The existing CF4.1 doesn't have replication setup
line 55: There is not separated mountpoint for /var/opt/rh/rh-postgresql94/lib/pgsql/data
line 62: The value of PG_LV_DEV is hardcoded in the script, volumen name doesn't match de default for the appliance (VG-CFME) and there is no by default separate logical volume for the mountpoint: /var/opt/rh/rh-postgresql94/lib/pgsql/data 
etc..


Version-Release number of selected component (if applicable):
cfme-appliance-5.7.0.17-1.el7cf

How reproducible:
Always

Steps to Reproduce:
1.Setup a CFME 4.1 in a default way
2.Try to upgrade, the script will fail.


Actual results:
Script fails.

Expected results:
Script works.

Additional info:

Comment 3 Nick Carboni 2017-01-13 19:27:15 UTC
Can you attach the output of the script when it fails?

When you mention particular lines of the script, are you saying it is failing and exiting at those lines?

At least I would not expect the bit about replication to fail the script (line 43).

Comment 4 Nick Carboni 2017-01-13 20:05:32 UTC
I was able to run the script successfully when replication was not configured.

It is expected that this script will not succeed when the database is not on a separate LV (as was described in https://bugzilla.redhat.com/show_bug.cgi?id=1387672#c4)

Because of this I am marking this as a duplicate of bug 1387672

*** This bug has been marked as a duplicate of bug 1387672 ***


Note You need to log in before you can comment on or make changes to this bug.