Bug 1411322 - Uploading overcloud images to undercloud Glance fails with: Unable to set 'is_public' to 'True'
Summary: Uploading overcloud images to undercloud Glance fails with: Unable to set 'is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 13:16 UTC by Marius Cornea
Modified: 2017-05-17 19:54 UTC (History)
12 users (show)

Fixed In Version: python-tripleoclient-5.7.1-0.20170106114513.9578dfa.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:54:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 387430 None None None 2017-01-10 18:15:33 UTC
Launchpad 1631052 None None None 2017-01-09 13:30:29 UTC

Description Marius Cornea 2017-01-09 13:16:56 UTC
Description of problem:
Unable to upload overcloud images to the undercloud Glance:

[stack@undercloud-0 ~]$ source ~/stackrc; openstack overcloud image upload --update-existing
Unable to set 'is_public' to 'True'

Version-Release number of selected component (if applicable):
python-tripleoclient-6.0.0-0.20161028122504.95bbccf.el7ost.noarch
openstack-tripleo-common-6.0.0-0.20161021193416.2af623f.el7ost.noarch
openstack-glance-14.0.0-0.20161220073709.9622151.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install undercloud
2. Upload images with: openstack overcloud image upload --update-existing

Actual results:
Unable to set 'is_public' to 'True'

Expected results:
Uploading the images is successful.

Additional info:

Comment 1 Marius Cornea 2017-01-09 13:30:05 UTC
Workaround: 

openstack --os-image-api-version 1 overcloud image upload --update-existing

Comment 2 Alex Schultz 2017-01-10 18:15:34 UTC
I think this is an issue with the version of the client you're using as this was addressed by https://review.openstack.org/#/c/387430/ which was from 11/16 but you're using a package from 10/21.  Please validate this is still an issue with a package that includes the glance v2 fix.

Comment 3 Alex Schultz 2017-01-10 18:28:12 UTC
Moving to Release Delivery as this is a puddle issue. The fix has already been committed upstream and this will be solved with updated packages.

Comment 7 Emilien Macchi 2017-03-01 21:17:02 UTC
Fixed upstream. Can someone check if Director works now?

Comment 8 errata-xmlrpc 2017-05-17 19:54:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.