Bug 1411325 - ovirt 4.1 rest api is sending unexpected results
Summary: ovirt 4.1 rest api is sending unexpected results
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libgovirt
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Eduardo Lima (Etrunko)
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On:
Blocks: 1445276
TreeView+ depends on / blocked
 
Reported: 2017-01-09 13:33 UTC by Andrei Stepanov
Modified: 2017-08-01 15:04 UTC (History)
3 users (show)

Fixed In Version: libgovirt-0.3.3-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1445276 (view as bug list)
Environment:
Last Closed: 2017-08-01 15:04:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
remote-viewer log with export REST_DEBUG=proxy + export G_DEBUG=fatal-criticals + export SPICE_DEBUG=1 (79.41 KB, text/plain)
2017-01-09 13:35 UTC, Andrei Stepanov
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 779026 0 Normal RESOLVED Add support for new storage domain format 2021-01-19 07:54:30 UTC
Red Hat Product Errata RHBA-2017:1849 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2017-08-01 17:49:46 UTC

Description Andrei Stepanov 2017-01-09 13:33:28 UTC
virt-viewer prints next message while opening connection to a guest at RHV 4.1:

(remote-viewer:29690): libgovirt-CRITICAL **: file ovirt-utils.c: line 152 (ovirt_utils_genum_get_value): should not be reached

How reproducible: always

ovirt-guest-agent-common-1.0.13-3.el6.noarch.rpm (Guest)
qemu-kvm-1.5.3-126.el7_3.3.x86_64 (Host)
ovirt-engine-4.1.0-0.3.beta2.el7.noarch (Engine)
virt-viewer-2.0-12.el7.x86_64 (Client)
libgovirt-0.3.3-4.el7.x86_64 (Client)


Steps to Reproduce:
1. Open terminal
2. Save .vv from RHV portal
3. remote-viewer ~/Downloads/console.vv

There is no such message while connecting to RHEV 3.6

Comment 1 Andrei Stepanov 2017-01-09 13:35:56 UTC
Created attachment 1238773 [details]
remote-viewer log with export REST_DEBUG=proxy + export G_DEBUG=fatal-criticals + export SPICE_DEBUG=1

Comment 3 Eduardo Lima (Etrunko) 2017-02-13 15:20:45 UTC
(In reply to Andrei Stepanov from comment #0)
> virt-viewer prints next message while opening connection to a guest at RHV
> 4.1:
> 
> (remote-viewer:29690): libgovirt-CRITICAL **: file ovirt-utils.c: line 152
> (ovirt_utils_genum_get_value): should not be reached

I tracked this down and it seems the server is sending "v4", which is not handled, but it seems to work as expected.

Comment 4 Andrei Stepanov 2017-02-28 14:37:24 UTC
The same is true for mingw remote-viewer 2.0 208
rpm -q --changelog spice-client-msi-x86-4.1-6.el7ev.noarch
* Wed Feb 08 2017 Uri Lublin <uril@redhat.com> - 4.1-6
- spec: fix changelog (rhbz#1405612)

* Wed Feb 08 2017 Uri Lublin <uril@redhat.com> - 4.1-5
- spec: fix Obsoletes (rhbz#1405612)

* Thu Dec 22 2016 Uri Lublin <uril@redhat.com> - 4.1-4
- mingw-virt-viewer 2.0-13
- mingw-spice-gtk   0.31-6

Comment 5 Eduardo Lima (Etrunko) 2017-03-06 15:13:05 UTC
The fix is merged upstream https://git.gnome.org/browse/libgovirt/commit/?id=145880f32823672e7c4fd5814ae6f2c5a0010756

Comment 8 errata-xmlrpc 2017-08-01 15:04:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1849


Note You need to log in before you can comment on or make changes to this bug.