Bug 141133 - Edit->Preferences->General missing "Checking for and setting default browser"
Edit->Preferences->General missing "Checking for and setting default browser"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 10:50 EST by Andres Escallon
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 04:39:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andres Escallon 2004-11-29 10:50:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The General Preferences Dialog use to have a way to set Firefox as the
default browser. Now is missing

Updating the browser, KDE lost the default browser setting. I can't
set  firefox as the default browser.



Version-Release number of selected component (if applicable):
firefox-1.0-2.fc3

How reproducible:
Always

Steps to Reproduce:
1.Select Edit->Preferences->General
2.
3.
    

Additional info:
Comment 1 Christopher Aillon 2004-12-04 04:39:45 EST
The default browser thing was for GNOME only, and it did not properly integrate
with everything (which you are seeing if you clicked on it at any point -- it
should never need to be changed with each upgrade, but it set itself up
stupidly, which is why I disabled it in the first place).

In GNOME, the correct way to set it up is to use
gnome-default-applications-properties (Main GNOME menu > Preferences > More
Preferences > Default Applications).  This is what the default application thing
in Mozilla tried to do but failed.  Not sure how to do it in KDE, but since this
was a GNOME thing only, it probably won't have an effect on you unless KDE reads
settings from GNOME.  In that case, use the suggestion here to fix your default
application and it will never need touching when you upgrade.

Note You need to log in before you can comment on or make changes to this bug.