Bug 1411330 - openshift-jvm OSGi console broken internal links
Summary: openshift-jvm OSGi console broken internal links
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.4.z
Assignee: Alexandre Kieling
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 13:53 UTC by Marek Schmidt
Modified: 2017-01-31 20:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Code was ported from hawtio v1 to hawtio v2 and the way the links are specified has changed. Consequence: There are some broken links on the OSGi pages, e.g. Bundles table and Packages table Fix: Changed the links to the correct way in hawtio v2, which includes the relative path and navigation information. Result: The broken links are not broken anymore.
Clone Of:
Environment:
Last Closed: 2017-01-31 20:19:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0218 0 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.4.1.2 bug fix update 2017-02-01 01:18:20 UTC

Description Marek Schmidt 2017-01-09 13:53:22 UTC
Description of problem:

In the openshift-jvm OSGi console, the internal links to packages/bundles/etc are broken by pointing to OPENSHIFT_URL/osgi/... instead of OPENSHIFT_URL/console/java/osgi/...

e.g. generates a link to

https://api.devel.xpaas:8443/osgi/package/com.ctc.wstx.osgi/4.4.1

instead of the working

https://api.devel.xpaas:8443/console/java/osgi/package/com.ctc.wstx.osgi/4.4.1?main-tab=osgi&sub-tab=osgi-packages&con=s2i-karaf2-camel-amq

Following the borken links lead to an error page.

Version-Release number of selected component (if applicable):

atomic-openshift 3.4.0.38-1.git.0.8561cba.el7

openshift-jvm
Version: 1.0.57
Commit ID: 80441ef1187ce1807e5ce5ea994d869a2c272fcc

How reproducible:
Always

Steps to Reproduce:
1. Deploy a version of karaf2-camel-amq FIS quickstart, e.g.

oc create -f https://raw.githubusercontent.com/maschmid/karaf2-camel-amq/bz1393711/karaf2-camel-amq-template.json
oc process s2i-karaf2-camel-amq | oc create -f -

and wait for the build and deployment

2. open the openshift console and find the s2i-karaf2-camel-amq-1-xxxx pod  
3. open the "Java Console" on the pod
4. open the OSGi tab
5. open the Packages sub-tab
6. notice the links on the packages or versions, try to follow some

Actual results:

An error page occurs, such as

{
  "kind": "Status",
  "apiVersion": "v1",
  "metadata": {},
  "status": "Failure",
  "message": "User \"system:anonymous\" cannot \"get\" on \"/osgi/package/com.ctc.wstx.osgi/4.4.1\"",
  "reason": "Forbidden",
  "details": {},
  "code": 403
}

Expected results:

User is redirected to the selected package or version inside the console

Additional info:

Comment 1 Alexandre Kieling 2017-01-11 18:58:38 UTC
Fixes available in openshift-jvm 1.0.60

Comment 2 Jessica Forrester 2017-01-11 21:26:53 UTC
PR is here https://github.com/openshift/origin-web-console/pull/1101

Comment 3 Jessica Forrester 2017-01-11 21:35:49 UTC
Fix for master branch is in https://github.com/openshift/origin-web-console/pull/1102

Comment 4 Jessica Forrester 2017-01-17 16:15:38 UTC
both PRs have merged

Comment 6 XiaochuanWang 2017-01-26 08:37:09 UTC
Verified on v3.4.1.2 followed steps in "Steps to Reproduce" in comment 0

Comment 8 errata-xmlrpc 2017-01-31 20:19:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0218


Note You need to log in before you can comment on or make changes to this bug.