Bug 1411395 - Upgrade QCI 1.0 -> latest: traceback while running yum update
Summary: Upgrade QCI 1.0 -> latest: traceback while running yum update
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer
Version: 1.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.1
Assignee: jkim
QA Contact: Sudhir Mallamprabhakara
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 15:45 UTC by Antonin Pagac
Modified: 2017-01-16 16:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 16:19:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Yum update output for v1.0 to v1.1 upgrade on 2017-01-12 (939.90 KB, text/plain)
2017-01-13 01:27 UTC, jkim
no flags Details

Description Antonin Pagac 2017-01-09 15:45:06 UTC
Description of problem:
While doing 'yum update -y' on the fusor machine, there is a traceback shown. The update continues normally and QCI is upgraded successfully in the end.

"
Updating   : selinux-policy-targeted-.13.1-102.el7_3.7.noarch 
‘/etc/selinux/targeted/modules/active/booleans.local’ -> ‘/etc/selinux/targeted/active/booleans.local’
‘/etc/selinux/targeted/modules/active/file_contexts.local’ -> ‘/etc/selinux/targeted/active/file_contexts.local’
‘/etc/selinux/targeted/modules/active/ports.local’ -> ‘/etc/selinux/targeted/active/ports.local’
ERROR: ERROR: policydb version 30 does not match my version range 15-29
policydb version 30 does not match my version range 15-29
ERROR: ERROR: Unable to open policy //etc/selinux/targeted/policy/policy.30.Unable to open policy //etc/selinux/targeted/policy/policy.30.

Traceback (most recent call last):
Traceback (most recent call last):
  File "/usr/sbin/semanage", line 32, in <module>
  File "/usr/sbin/semanage", line 32, in <module>
        import seobject
import seobject
  File "/usr/lib/python2.7/site-packages/seobject/__init__.py", line 27, in <module>
  File "/usr/lib/python2.7/site-packages/seobject/__init__.py", line 27, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 798, in <module>
    import sepolicy
  File "/usr/lib64/python2.7/site-packages/sepolicy/__init__.py", line 798, in <module>
    raise e
    raise e
ValueErrorValueError: : Failed to read //etc/selinux/targeted/policy/policy.30 policy fileFailed to read //etc/selinux/targeted/policy/policy.30 policy file
"

Version-Release number of selected component (if applicable):
upgrading to 20170106.t.0

How reproducible:
reproduced twice

Steps to Reproduce:
1. Install QCI 1.0 GA ISO
2. Do the procedure of upgrading QCI to the latest version
3. During the 'yum update' step, watch the output

Actual results:
Traceback shown during the 'yum update' step

Expected results:
No traceback

Additional info:

Comment 2 Jason Montleon 2017-01-09 19:35:16 UTC
Do you think this has something to do with a fusor package for some reason? I don't see anything fusor related in the traceback.

Comment 3 jkim 2017-01-13 01:27:01 UTC
Created attachment 1240176 [details]
Yum update output for v1.0 to v1.1 upgrade on 2017-01-12

Could not reproduce the trace with the following procedures
- Installed the QCI v1.0 ISO
- Sucessfully deployed RHV & CFME & OSE
- Prep the Satellite VM for upgrade
- Ran 'yum update -y'

Comment 4 Antonin Pagac 2017-01-16 11:28:44 UTC
I failed to reproduce the issue today.

Comment 5 John Matthews 2017-01-16 16:19:25 UTC
Moving to CLOSED as we couldn't reproduce.

Please reopen if you see this again.


Note You need to log in before you can comment on or make changes to this bug.