Bug 1411396 - Overcloud deployment fails with ailed to validate nested template: Property error: resources[8].properties: Property KeystoneFernetKey1 not assigned"
Summary: Overcloud deployment fails with ailed to validate nested template: Property e...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 15:47 UTC by Marius Cornea
Modified: 2017-05-17 19:55 UTC (History)
13 users (show)

Fixed In Version: python-tripleoclient-5.7.1-0.20170106114513.9578dfa.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:55:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 397381 None None None 2017-01-10 18:19:25 UTC

Description Marius Cornea 2017-01-09 15:47:21 UTC
Description of problem:
Overcloud deployment fails with ailed to validate nested template: Property error: resources[8].properties: Property KeystoneFernetKey1 not assigned"

Version-Release number of selected component (if applicable):
python-tripleoclient-6.0.0-0.20161028122504.95bbccf.el7ost.noarch
openstack-tripleo-common-6.0.0-0.20161021193416.2af623f.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-0.20161220000655.58d711e.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud:
source ~/stackrc
export THT=/usr/share/openstack-tripleo-heat-templates/

openstack overcloud deploy --templates $THT \
-r ~/openstack_deployment/roles/roles_data.yaml \
-e $THT/environments/puppet-pacemaker.yaml \
-e $THT/environments/network-isolation.yaml \
-e $THT/environments/network-management.yaml \
-e $THT/environments/storage-environment.yaml \
-e ~/openstack_deployment/environments/nodes.yaml \
-e ~/openstack_deployment/environments/network-environment.yaml \
-e ~/openstack_deployment/environments/disk-layout.yaml \
-e ~/openstack_deployment/environments/neutron-settings.yaml

Actual results:
Deployment fails fast with the following error:
 u'message': u"Failed to run action [action_ex_id=3974d6f1-862e-4064-b7e1-5c1df8f03835, action_cls='<class 'mistral.actions.action_factory.DeployStackAction'>', attributes='{}', params='{u'container': u'overcloud', u'timeout': 240}']\n ERROR: Failed to validate: : resources.ServiceApiServiceChain: : Failed to validate nested template: Property error: resources[8].properties: Property KeystoneFernetKey1 not assigned",
 u'status': u'FAILED'}


Expected results:
Deployment proceeds.

Additional info:
Workaround: pass the following parameters in an environment file:
parameter_defaults:
  KeystoneFernetKey1: azerty
  KeystoneFernetKey0: azerty

Comment 1 Alex Schultz 2017-01-10 18:19:26 UTC
This looks like the tripleo-common package being used does not contain the upstream fix. Please validate with a newer package as this was fixed upstream on 11/18 by https://review.openstack.org/#/c/397381/

Comment 2 Alex Schultz 2017-01-10 18:27:50 UTC
Moving to Release Delivery as this is a puddle issue. The fix has already been committed upstream and this will be solved with updated packages.

Comment 7 errata-xmlrpc 2017-05-17 19:55:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.