Bug 1411403 - Coreutils not displaying thousands separator
Summary: Coreutils not displaying thousands separator
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: coreutils
Version: 25
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Kamil Dudka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 16:07 UTC by Greg Oliver
Modified: 2017-01-09 20:40 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-09 20:40:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Greg Oliver 2017-01-09 16:07:34 UTC
Description of problem:

Coreutils - coreutils-8.25-15.fc25.x86_64 does not display thousands separator properly.

Version-Release number of selected component (if applicable):

coreutils-8.25-15.fc25.x86_64

How reproducible:

100%

Steps to Reproduce:
1.  unalias ls && ls -l --block-size="'1"
2.
3.

Actual results:

-rw-r--r-- 1 greg greg  75434 Oct 31 12:12 coreutils.spec
-rw-r--r-- 1 greg greg 172107 Dec 25 12:42 kernel.spec

Expected results:

-rw-r--r-- 1 greg greg  75,434 Oct 31 12:12 coreutils.spec
-rw-r--r-- 1 greg greg 172,107 Dec 25 12:42 kernel.spec

Additional info:

sudo locale
LANG=C
LC_CTYPE="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_MESSAGES="C"
LC_PAPER="C"
LC_NAME="C"
LC_ADDRESS="C"
LC_TELEPHONE="C"
LC_MEASUREMENT="C"
LC_IDENTIFICATION="C"
LC_ALL=C
[greg@macbook SPECS]$ !1036
sudo localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: us
      X11 Layout: us

Comment 1 Pádraig Brady 2017-01-09 17:56:05 UTC
can repro here, not has ls changed in this regard recently.
I'm guessing you're still in the C locale. Do you need to relogin?
Can you reproduce with LC_ALL=en_US.UTF-8 specified?

Comment 2 Pádraig Brady 2017-01-09 17:57:36 UTC
I meant to say; I can't reproduce here, and nothing has changed in ls in this regrard recently

Comment 3 Greg Oliver 2017-01-09 20:40:14 UTC
That works - sorry for the noise - I added an entry for LC_ in my bashrc for another product and forgot about it!

Thanks.


Note You need to log in before you can comment on or make changes to this bug.