Bug 1411426 - appliance_console does not ask for region number when using internal database
Summary: appliance_console does not ask for region number when using internal database
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.7.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: GA
: cfme-future
Assignee: Yuri Rudman
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 17:02 UTC by Reartes Guillermo
Modified: 2017-01-18 04:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 15:33:08 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
cfme 5.7.0 creating database (no region number was asked not shown) (12.67 KB, image/png)
2017-01-09 17:04 UTC, Reartes Guillermo
no flags Details
cfme 5.6.3.3, the region number was asked and it is also shown (91.78 KB, image/png)
2017-01-09 17:05 UTC, Reartes Guillermo
no flags Details

Description Reartes Guillermo 2017-01-09 17:02:53 UTC
Description of problem:

Hi,

I tried to deploy CloudForms 4.2 but failed due to the fact that appliance_console did not create any region in the internal database.

I was puzzled, but in fact, the problem is that appliance_console did not ever ask for any region number!


Version-Release number of selected component (if applicable):
5.7.0

How reproducible:
always

Steps to Reproduce:
1. boot the appliance
2. add another disk (vdb) for the appliance
3. check that the new disk is recognized (lsblk)
4. execute appliance_console
5. option 2, set static ip
6. option 4, set hostname
7. option 8, Configure Database
8. suboption 1, create key
9. suboption 1, create internal database
10. suboption 1, vdb disk
11. question, dedicated database appliance, Y
12. enter database password 127.0.0.1
13. confirm database password
14. database is created, but at no moment did the appliance_console ask for a region number.


Actual results:
unable to create any region in the internal database, broken workflow, no CloudForms 4.2.

Expected results:
appliance_console should ask the region number and create it when using internal database. (assuming docs are ok).


Additional Info:
I tried back with 5.6.3.3 and it works ok.

Comment 2 Reartes Guillermo 2017-01-09 17:04:11 UTC
Created attachment 1238827 [details]
cfme 5.7.0 creating database (no region number was asked not shown)

Comment 3 Reartes Guillermo 2017-01-09 17:05:20 UTC
Created attachment 1238829 [details]
cfme 5.6.3.3, the region number was asked and it is also shown


Note You need to log in before you can comment on or make changes to this bug.