This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 141143 - RHEL4-B2-X86-Dmesg shows "ide1: Wait for ready failed before probe "
RHEL4-B2-X86-Dmesg shows "ide1: Wait for ready failed before probe "
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 11:37 EST by Stuart Hayes
Modified: 2015-01-04 17:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 17:08:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stuart Hayes 2004-11-29 11:37:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET 
CLR 1.1.4322)

Description of problem:
After booting a Dell PE2650 into RHEL4 beta 2, dmesg has the 
following messages:

"ide1: Wait for ready failed before probe "

System configuration:

System : PE2650 
BIOS : A20
H/W config : 2* 2.4 Ghz /12GB 
memory /PERC3Di/PERC4DC/Intel1000MT/2*BCM570X/AIC-39160

Comments (from Amit Bhutani):

Looks like this got introduced in the 2.6.9 kernel.

This is what the IDE maintainer (Bartlomiej Zolnierkiewicz) had to 
say about it --> 
http://www.ussg.iu.edu/hypermail/linux/kernel/0410.3/0066.html

Looks like someone needs to write a patch as Bartlomiej indicated to 
replace the printks with pr_debugs and submit the patch to 
kernel.org. This may already be done. Just need to verify. Absolutely 
need to open a Bugzilla against Red Hat to ensure that patch gets 
included in RHEL 4 RC.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot up system
2. look at dmesg
3.
    

Actual Results:  error message above is in log

Expected Results:  no errors in log

Additional info:
Comment 1 Alan Cox 2004-11-29 16:07:19 EST
These are debug level messages not errors. They were switched to pr_debug in
2.6.10rc once we were happy with testing the changes.
Comment 2 Stuart Hayes 2004-11-29 16:17:12 EST
I just found that out when I tried to reproduce this myself.
Thanks!
Comment 3 Amit Bhutani 2004-12-07 17:08:17 EST
Verified fixed in 860 build. Thanks. Closing.

Note You need to log in before you can comment on or make changes to this bug.