Bug 14115 - gcc-2.96-33 builds non-bootable kernel 2.4.0-test5-pre1
Summary: gcc-2.96-33 builds non-bootable kernel 2.4.0-test5-pre1
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-17 14:11 UTC by Olivier Baudron
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-24 23:21:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olivier Baudron 2000-07-17 14:11:49 UTC
gcc-2.96-33 compiles kernel 2.4.0-test5-pre1 but when booting it hangs
after 'Starting kswapd v1.6'. I tried with egcs-1.1.2 and it boots just
fine, so the problem is probably a gcc issue, not a kernel one.
I inserted various 'printk("coucou\n")' in the code and it appears that the
problem occurs in linux/init/main.c lines 615--624:

static void __init do_initcalls(void)
{
	initcall_t *call;

	call = &__initcall_start;
	do {
		(*call)();
		call++;
	} while (call < &__initcall_end);
}

The first iteration, which threads kswapd, is correctly executed. In the
second, the computer hangs after (*call)(). Normally, if compiled with
egcs, the kernel outputs 'Detected PS/2 Mouse Port.' so it is possible that
the build problem is somewhere in the PS/2 driver.

Also note that kernel 2.4.0-test2 did not have this problem whereas
2.4.0-test4-pre6 did. I could not try with test3 because gcc was unable to
compile it.

Comment 1 Jakub Jelinek 2000-07-24 23:21:30 UTC
Am just testing new gcc fixes if the kernel works with them

Comment 2 Jakub Jelinek 2000-08-09 13:04:22 UTC
gcc in the current distribution builds a working kernel (last tried
2.4.0-test6-pre9)


Note You need to log in before you can comment on or make changes to this bug.