Bug 1411503 - [Intel OSP12] GUI to register Rack Scale Design (RSD) nodes with Ironic
Summary: [Intel OSP12] GUI to register Rack Scale Design (RSD) nodes with Ironic
Keywords:
Status: CLOSED DUPLICATE of bug 1397204
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo
Version: 12.0 (Pike)
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: James Slagle
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-09 21:02 UTC by Krish Raghuram
Modified: 2017-03-16 14:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 17:11:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Krish Raghuram 2017-01-09 21:02:32 UTC
1. Description of feature:
In RSD, the node resources (CPU, memory etc.) are disaggregated within a rack, and need to be composed and made visible as logical nodes within OpenStack. There is a RSD software layer (codenamed Valence) that interfaces with the hardware and does the node composition. It provides an API that can be used by deployment tools like TripleO to request node composition, and then register them with the Ironic module as new bare-metal nodes

Version-Release number of selected component (if applicable):
TripleO version in OpenStack Pike release

2. Business Justification:
  a) Why is this feature needed?
    RSD is a new architecture that realizes an agile infrastructure where the hardware resources can be pooled according to application needs. It also enables a more easily scaled infrastructure, so CPU, memory, network and storage resources can be added as needed, without the need to do complete replacements of nodes
  b) What hardware does this enable?
    RSD Server
  c) Is this hardware on-board in a system (eg, LOM) or an add-on card? 
    N/A
  d) Business impact? N/A
  e) Other business drivers: N/A

4. Primary contact at Partner, email, phone (chat)
   Nate Potter
   nathaniel.potter@intel.com (IRC: ntpttr)

5. Expected results: TripleO requests and registers RSD nodes with Ironic through a plug-in that uses the RSD software APIs


Additional info:
Standalone WebUI development: https://blueprints.launchpad.net/openstack-valence/+spec/web-ui-interface

Comment 1 Krish Raghuram 2017-01-13 17:11:22 UTC
Just noticed that this is a duplicate of BZ#1397204 that i had raised earlier and forgotten. This has a few more details

*** This bug has been marked as a duplicate of bug 1397204 ***


Note You need to log in before you can comment on or make changes to this bug.