Bug 141155 - fedora updates directory on ftp server needs tidying
Summary: fedora updates directory on ftp server needs tidying
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL: ftp://download.fedora.redhat.com/pub/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-29 18:03 UTC by Alex Butcher
Modified: 2014-03-17 02:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-29 20:44:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alex Butcher 2004-11-29 18:03:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020 Galeon/1.3.18

Description of problem:
There are duplicate versions of slang, slang-devel and redhat-menus in
the updates directory of the FTP site. This is a PITA.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. log into ftp://download.fedora.redhat.com
2. enter fc3 i386 updates directory
3. obtain a directory listing
    

Actual Results:  ftp> dir slang*
227 Entering Passive Mode (66,187,224,20,56,192)
150 Here comes the directory listing.
-rw-r--r--    2 ftp      ftp        389990 Nov 19 21:46
slang-1.4.9-13.i386.rpm
-rw-r--r--    2 ftp      ftp        389798 Nov 08 19:36
slang-1.4.9-7.i386.rpm
-rw-r--r--    1 ftp      ftp        532792 Nov 19 21:46
slang-devel-1.4.9-13.i386.rpm
-rw-r--r--    1 ftp      ftp        532531 Nov 08 19:36
slang-devel-1.4.9-7.i386.rpm
226 Directory send OK.
ftp> dir redhat-menu*
227 Entering Passive Mode (66,187,224,20,42,17)
150 Here comes the directory listing.
-rw-r--r--    2 ftp      ftp        154274 Nov 22 21:08
redhat-menus-3.7-2.2.fc3.noarch.rpm
-rw-r--r--    2 ftp      ftp        155024 Nov 23 01:56
redhat-menus-3.7.1-1.fc3.noarch.rpm
226 Directory send OK.

Expected Results:  No duplicate packages

Additional info:

Comment 1 Paul Nasrat 2004-11-29 18:13:40 UTC
Reassign to distribution.

Note using a depsolver such as up2date/yum will use repodata/headers
and choose the right package, and is the preferred method of updating.

Comment 2 Bill Nottingham 2004-11-29 20:44:36 UTC
Older versions are kept for (roughly) a month, and then removed.

Comment 3 Jason Baron 2004-12-20 18:33:06 UTC
*** Bug 136645 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.