Bug 14116 - bash messages when fsck fails and bash starts
bash messages when fsck fails and bash starts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.1
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-17 10:34 EDT by Matt Domsch
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 10:50:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2000-07-17 10:34:03 EDT
I get the following messages if fsck fails at startup, and it drops you to 
a bash shell.

bash: tput: command not found
bash: dircolors: command not found
bash: id: command not found
[: -: unary operator expected

The / partition is mounted, but /usr isn't, and these all live in /usr/bin.
Just kind of annoying, but doesn't really cause a problem.  Since these 
are all getting sourced from /etc/{profile,bashrc}, could simple logic be 
added to test for the existence of these programs before calling them?
Comment 1 Bernhard Rosenkraenzer 2000-07-17 10:50:00 EDT
Thanks, fixed in bash-2.04-8

Note You need to log in before you can comment on or make changes to this bug.