Bug 1411602 - qemu-system-x86 needs updated to a newer version
Summary: qemu-system-x86 needs updated to a newer version
Keywords:
Status: NEW
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qemu
Version: epel7
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 04:34 UTC by Jeff Waller
Modified: 2017-11-28 17:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Jeff Waller 2017-01-10 04:34:45 UTC
Description of problem:

smbios version 2 is not supported by the qemu-system-x86 provided by the latest epel 

qemu-system-x86_64: -smbios type=2: Don't know how to build fields for SMBIOS type 2
Version-Release number of selected component (if applicable):

How reproducible:

100%

Steps to Reproduce:
1. Attempt to use -smbios type=2 flag to qemu-system-x86_64

Actual results:

fails with the above error message.

Expected results:

no error

Additional info:

The error message appears to be a catch-all for any smbios that is not known. Here's a potentially relevant patch discussion:

https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg01548.html

qemu-system-x86_64 2.3 has been supported by Fedora versions no later than Fedora 22.  The latest Fedora (25) supports qemu 2.7 and rawhide support qemu-system 2.8.


Note You need to log in before you can comment on or make changes to this bug.