Bug 1411616 - lksctp-tools: sctp_test fails to connect via ipv6 socket
Summary: lksctp-tools: sctp_test fails to connect via ipv6 socket
Keywords:
Status: CLOSED DUPLICATE of bug 1400441
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lksctp-tools
Version: 6.9
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Rashid Khan
QA Contact: Network QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 06:47 UTC by Jayaraj
Modified: 2020-02-14 18:26 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 13:51:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jayaraj 2017-01-10 06:47:31 UTC
Description of problem:


When trying to run sctp_test and connect to an endpoint
with an ipv6 address it fails

Version-Release number of selected component (if applicable):
lksctp-tools-1.0.10-7.el6 on RHEL 6.9 Beta

How reproducible:
100%

Steps to Reproduce:
1. Start server `/usr/bin/sctp_status -H localhost -P 2222 -l`
2. Start client `/usr/bin/sctp_test -H localhost -P 2223 -h localhost -p 2222 -s`

Actual results:

remote:addr=::, port=EtherNet/IP-1, family=10
local:addr=::, port=rockwell-csp2, family=10
seed = 1484030671

Starting tests...
	socket(SOCK_SEQPACKET, IPPROTO_SCTP)  ->  sk=3
	bind(sk=3, [a:::,p:rockwell-csp2])  --  attempt 1/10
Client: Sending packets.(1/10)
	sendmsg(sk=3, assoc=0)    1 bytes.
	  SNDRCV(stream=0 flags=0x1 ppid=1727240551

		*** sendmsg: Invalid argument ***


Expected results:

Test completes.

Additional info:

The above test will work if the command line is modified to

/usr/bin/sctp_test -H localhost -P 2223 -h 127.0.0.1 -p 2222 -s

to force sctp_test to connect via ipv4.

The issue is fixed in RHEL 7.3 but it exists in RHEL 6.9 beta.

Comment 3 Jianwen Ji 2017-01-10 08:08:51 UTC
As Xin said, this should be duplicate of bz1400441


Note You need to log in before you can comment on or make changes to this bug.