Bug 1411635 - Include wrong sanlock package in redhat-virtualization-host-4.1-20170104.0
Summary: Include wrong sanlock package in redhat-virtualization-host-4.1-20170104.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.0-beta
: ---
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 07:54 UTC by cshao
Modified: 2017-04-20 19:02 UTC (History)
11 users (show)

Fixed In Version: redhat-virtualization-host-4.1-20170111.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 19:02:12 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1114 0 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update 2017-04-20 22:57:46 UTC

Description cshao 2017-01-10 07:54:27 UTC
Description of problem:
Include wrong sanlock package in redhat-virtualization-host-4.1-20170104.0

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20170104.0
RHVH-4.1-20170109.0-RHVH-x86_64-dvd1.iso
imgbased-0.9.2-0.1.el7ev.noarch
sanlock-3.2.4-2.el7_2.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH-4.1-20170109.0-RHVH-x86_64-dvd1.iso.
2. Login RHVH, check sanlock
  # rpm -qa | grep sanlock


Actual results:
After step2, Include sanlock-3.2.4-2.el7_2.x86_64


Expected results:
1. After step2, RHVH should include newer sanlock-3.4.0-1.el7.

Additional info:

Comment 1 Sandro Bonazzola 2017-01-10 09:38:37 UTC
Ryan please handle

Comment 3 Ryan Barry 2017-01-10 15:19:05 UTC
sanlock-3.2.4-2 is tagged directly into rhevm-4.0-rhel-7

We can change the inheritance tree in order to prioritize rhel* tags over rhev* tags, but I'd like to understand why sanlock is directly in RHEV tags before we change this...

Comment 4 cshao 2017-01-19 08:14:09 UTC
Test version:
rhvh-4.1-0.20170116.0
imgbased-0.9.4-0.1.el7ev.noarch
sanlock-3.4.0-1.el7.x86_64

Test result:
RHVH include the correct sanlock version, so the bug is fixed, change bug status to VERIFIED.

Comment 5 errata-xmlrpc 2017-04-20 19:02:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1114


Note You need to log in before you can comment on or make changes to this bug.