Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1411651 - SIGSEGV (0xb) C [libawt_xawt.so+0x40be9]
Summary: SIGSEGV (0xb) C [libawt_xawt.so+0x40be9]
Keywords:
Status: CLOSED DUPLICATE of bug 1402819
Alias: None
Product: Fedora
Classification: Fedora
Component: java-1.8.0-openjdk
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Deepak Bhole
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 08:44 UTC by Mauri Sahlberg
Modified: 2017-01-10 11:13 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 11:13:17 UTC
Type: Bug


Attachments (Terms of Use)
Openjdk produced "problem" report (87.86 KB, text/plain)
2017-01-10 08:44 UTC, Mauri Sahlberg
no flags Details

Description Mauri Sahlberg 2017-01-10 08:44:40 UTC
Created attachment 1239011 [details]
Openjdk produced "problem" report

Description of problem:
While running DB Visualizer - a java application - starting wizard to add new database connection. Wizard asks to select a driver from dropdown. Choosing the dropdown freezes whole ui and causes the DB Visualizer to crash

Version-Release number of selected component (if applicable):
JRE version: OpenJDK Runtime Environment (8.0_111-b16) (build 1.8.0_111-b16)
# Java VM: OpenJDK 64-Bit Server VM (25.111-b16 mixed mode linux-amd64 compressed oops)


How reproducible:
Always

Steps to Reproduce:
1. Open DB Visualizer
2. Create new database connection with wizard
3. Click driver dropdown

Actual results:
Whole Gnome UI freezes for a while. Application ends.

Expected results:
List of drivers to choose from

Additional info:
Tested with two different hardwares - Fujitsu desktop and HP laptop both running FC 25. Crash.

Comment 1 Severin Gehwolf 2017-01-10 10:27:37 UTC
Is this running Gnome on wayland? If so, does the same happen when running on X?

Comment 2 Severin Gehwolf 2017-01-10 10:31:03 UTC
From the stack trace:

Stack: [0x00007fbda009d000,0x00007fbda019e000],  sp=0x00007fbda0198260,  free space=1004k
Native frames: (J=compiled Java code, j=interpreted, Vv=VM code, C=native code)
C  [libawt_xawt.so+0x40be9]
C  [libawt_xawt.so+0x412fd]
C  [libawt_xawt.so+0x388e3]  Java_sun_awt_X11_XRobotPeer_getRGBPixelsImpl+0x1f3
j  sun.awt.X11.XRobotPeer.getRGBPixelsImpl(Lsun/awt/X11GraphicsConfig;IIII[I)V+0
j  sun.awt.X11.XRobotPeer.getRGBPixels(Ljava/awt/Rectangle;)[I+33
j  java.awt.Robot.createScreenCapture(Ljava/awt/Rectangle;)Ljava/awt/image/BufferedImage;+50

java.awt.Robot.createScreenCapture() showing up there suggests it might be related to bug 1402819 if run on wayland.

Comment 3 Mauri Sahlberg 2017-01-10 11:00:41 UTC
(In reply to Severin Gehwolf from comment #1)
> Is this running Gnome on wayland? If so, does the same happen when running
> on X?

Under Wayland. How do I run it under X instead?

Comment 4 Mauri Sahlberg 2017-01-10 11:08:46 UTC
Application doesn't crash if the outlying session is started as Gnome + X.org.

Comment 5 Severin Gehwolf 2017-01-10 11:11:52 UTC
(In reply to Mauri Sahlberg from comment #3)
> How do I run it under X instead?

The "How to Test" section of the Wayland Change page has some details as to how to switch between the two:
https://fedoraproject.org/wiki/Changes/WaylandByDefault#How_To_Test

Comment 6 Severin Gehwolf 2017-01-10 11:13:17 UTC
Closing as duplicate based on comment 4.

*** This bug has been marked as a duplicate of bug 1402819 ***


Note You need to log in before you can comment on or make changes to this bug.