Bug 1411658 - some of the modules in gdeploy does not have ignore_error feature
Summary: some of the modules in gdeploy does not have ignore_error feature
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: RHGS 3.2.0
Assignee: Sachidananda Urs
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2 1351528
TreeView+ depends on / blocked
 
Reported: 2017-01-10 09:07 UTC by RamaKasturi
Modified: 2017-03-23 05:09 UTC (History)
6 users (show)

Fixed In Version: gdeploy-2.0.1-9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 05:09:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0482 normal SHIPPED_LIVE Red Hat Gluster Storage 3.2.0 gdeploy bug fix and enhancement update 2017-03-23 09:06:28 UTC

Description RamaKasturi 2017-01-10 09:07:01 UTC
Description of problem:
Implement ignore_blah_error feature for the following modules in gdeploy.
1) Run a command in shell commands does not have this feature.
2) Add / delete services does not have this feature.
3) start/stop/restart/reload services does not have this feature.
4) setup_cache section does not have this feature.
5) Running a shell script does not have this feature.
6) Update-file does not have this feature.

Version-Release number of selected component (if applicable):
gdeploy-2.0.1-8.el7rhgs.noarch

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:
Above listed modules does not have ignore_errors feature implemented.

Expected results:
All the modules present in hc.conf file should have ignore_error feature implemented so that user can abort the setup if something fails instead of proceeding further.

Additional info:

Comment 2 RamaKasturi 2017-01-11 08:51:54 UTC
proposing this as blocker since ignore_error=no feature is required for running a shell script since the bug fix for [1]  is going to be a script and if this feature is not present it might just ignore the errors and continue even if there is some failure.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1405447

Comment 3 Sachidananda Urs 2017-01-25 07:50:05 UTC
Commit: https://github.com/gluster/gdeploy/commit/43ed3294 fixes the issue.

Comment 5 SATHEESARAN 2017-02-17 16:23:07 UTC
Most of the gdeploy modules have ignore_x_errors
-----------------------------
lv module
-----------------------------
ignore_lv_errors
ignore_mount_errors
-----------------------------
pv module
-----------------------------
ignore_pv_errors
-----------------------------
subscription
-----------------------------
ignore_register_errors
ignore_unregister_errors
ignore_enable_errors
ignore_disable_errors
ignore_attach_pool_errors
-----------------------------
script
-----------------------------
ignore_script_errors

service_errors
-----------------------------
ignore_service_errors

shell
-----------------------------
ignore_shell_errors

update_file
-----------------------------
ignore_update_file_errors

vg
-----------------------------
ignore_vg_errors

volume
-----------------------------
ignore_volume_errors

yum
-----------------------------
ignore_yum_errors

Verified the same with negative cases for each section

Comment 6 SATHEESARAN 2017-02-17 16:23:55 UTC
(In reply to SATHEESARAN from comment #5)
> Most of the gdeploy modules have ignore_x_errors

Tested with gdeploy-2.0.1-11.el7rhgs

Comment 8 errata-xmlrpc 2017-03-23 05:09:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0482.html


Note You need to log in before you can comment on or make changes to this bug.