Bug 1411670 - Add DeployIndentifier parameter in section 9.3 (customizing overcloud post-configuration) of Director Installation and Usage.
Summary: Add DeployIndentifier parameter in section 9.3 (customizing overcloud post-co...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 7.0 (Kilo)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 09:21 UTC by Navneet Krishnan
Modified: 2020-04-15 15:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 04:15:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Navneet Krishnan 2017-01-10 09:21:12 UTC
Description of problem: The documentation to set-up the post-deploy script is missing the DeploymentIdentifier paramater. 

 The documentation for OS::TripleO::NodeExtraConfigPost [1] does not include a DeployIdentifier parameter, so the configuration will only be applied during initial stack creation (or when something in the configuration actually changes). This when the OS::TripleO::NodeExtraConfigPost is overriding settings applied by puppet since these are run on every stack update.

The doc in question is:
 https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Configuring_after_Overcloud_Creation.html

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

The documentation should be up

Additional info:

Comment 1 Navneet Krishnan 2017-01-10 09:44:02 UTC
This traces its root from https://bugzilla.redhat.com/show_bug.cgi?id=1312007

An example configuration is give here: 

https://review.openstack.org/#/c/296488/1/extraconfig/post_deploy/example_run_on_update.yaml

Even though this procedure is documented for RHOS 7 , it may effect subsequent versions (RHOS 8,9,10 ) also: (refer section 9.3)

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Configuring_after_Overcloud_Creation.html

Comment 2 Dan Macpherson 2018-04-09 04:15:58 UTC
This appears to be fixed for OSP7 now. Have checked subsequent versions and DeployIdentifier seems to be used throughout.


Note You need to log in before you can comment on or make changes to this bug.