Bug 1411678 - Virt-viewer cannot connect to guest when graphics listen type is network
Summary: Virt-viewer cannot connect to guest when graphics listen type is network
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.4
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Virt Viewer Maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1410671
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 09:38 UTC by Xiaodai Wang
Modified: 2017-01-10 11:44 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1410671
Environment:
Last Closed: 2017-01-10 10:30:27 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Jiri Denemark 2017-01-10 10:30:27 UTC
(In reply to xiaodwan from comment #0)
> This also occurs when connecting to a rhel6 guest on rhel7.

I'm not sure what you wanted to say. The guest operating system is really irrelevant here.

And the bug is really useless since you cloned it with all private comments. Please file a new one or clone the existing one, but make sure you remove all irrelevant comments so the the bug description can be public. And don't forget to provide information specific to the rhel7, such as package versions.

Anyway, since it seems like it happens only in some specific scenarios in rhel7, it may be better to file a new bug from scratch describing what works and what doesn't work.

Comment 2 Xiaodai Wang 2017-01-10 10:54:49 UTC
(In reply to Jiri Denemark from comment #1)
> (In reply to xiaodwan from comment #0)
> > This also occurs when connecting to a rhel6 guest on rhel7.
> 
> I'm not sure what you wanted to say. The guest operating system is really
> irrelevant here.
> 

Hi, This is not about guest OS. 
The scenario here is connecting a "listen type='network'" guest on rhel6 from rhel7 by virt-viewer.

If you agree, i want to make the comment #0 public and reopen this bug.

Comment 3 Jiri Denemark 2017-01-10 11:04:25 UTC
(In reply to xiaodwan from comment #2)
> (In reply to Jiri Denemark from comment #1)
> Hi, This is not about guest OS. 
> The scenario here is connecting a "listen type='network'" guest on rhel6
> from rhel7 by virt-viewer.

So the domain is running on a rhel6 host and you are connecting to a virt-viewer running on a rhel7 host, is that right? Does it all work if both the domain and virt-viewer are running on rhel7?

> If you agree, i want to make the comment #0 public and reopen this bug.
No, making it public is easy, but the main point is that comment #0 contains a lot of irrelevant comments because you didn't remove them before saving the clone. And this can't be fixed.

Comment 4 Xiaodai Wang 2017-01-10 11:44:58 UTC
> So the domain is running on a rhel6 host and you are connecting to a
> virt-viewer running on a rhel7 host, is that right? 
Yes
> Does it all work if both the domain and virt-viewer are running on rhel7?
This works.

> > If you agree, i want to make the comment #0 public and reopen this bug.
> No, making it public is easy, but the main point is that comment #0 contains
> a lot of irrelevant comments because you didn't remove them before saving
> the clone. And this can't be fixed.

Thanks. I'll file a new bug for the different scenario on rhel7.


Note You need to log in before you can comment on or make changes to this bug.