Bug 1411683 - Ceilometer stanza gets configured in HAProxy even though there's no Ceilometer API running on the backend servers
Summary: Ceilometer stanza gets configured in HAProxy even though there's no Ceilomete...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Upstream M3
: 11.0 (Ocata)
Assignee: Pradeep Kilambi
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 09:44 UTC by Marius Cornea
Modified: 2017-05-17 19:55 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170120220935.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:55:48 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 420081 None None None 2017-01-13 17:22:54 UTC
OpenStack gerrit 420087 None None None 2017-01-13 17:23:31 UTC

Description Marius Cornea 2017-01-10 09:44:25 UTC
Description of problem:
Ceilometer stanza gets configured in HAProxy even though there's no Ceilometer API running on the backend servers

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.20161220000655.58d711e.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy overcloud. Check HAProxy config on overcloud controllers:

listen ceilometer
  bind 10.0.0.12:8777 transparent
  bind 172.16.18.29:8777 transparent
  mode http
  http-request set-header X-Forwarded-Proto https if { ssl_fc }
  http-request set-header X-Forwarded-Proto http if !{ ssl_fc }
  server overcloud-serviceapi-0.internalapi.localdomain 10.0.0.21:8777 check fall 5 inter 2000 rise 2
  server overcloud-serviceapi-1.internalapi.localdomain 10.0.0.17:8777 check fall 5 inter 2000 rise 2

Actual results:
There is no Ceilometer API binding on 10.0.0.21:8777 or 10.0.0.17:8777.

Expected results:
AFAIK the Ceilometer API is being deprecated in OSP11 and disabled by default. In this case I think we should not configure the Ceilometer stanza in haproxy.cfg

Comment 7 Marius Cornea 2017-05-03 12:37:14 UTC
listen ceilometer
  bind 10.0.0.13:8777 transparent
  bind 172.16.18.25:13777 transparent ssl crt /etc/pki/tls/private/overcloud_endpoint.pem
  mode http
  http-request set-header X-Forwarded-Proto https if { ssl_fc }
  http-request set-header X-Forwarded-Proto http if !{ ssl_fc }
  server overcloud-controller-0.internalapi.localdomain 10.0.0.12:8777 check fall 5 inter 2000 rise 2
  server overcloud-controller-1.internalapi.localdomain 10.0.0.23:8777 check fall 5 inter 2000 rise 2
  server overcloud-controller-2.internalapi.localdomain 10.0.0.25:8777 check fall 5 inter 2000 rise 2

All the backends are up.

Comment 8 errata-xmlrpc 2017-05-17 19:55:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.