Bug 141169 - "error starting the GNOME Settings Daemon" at startup
"error starting the GNOME Settings Daemon" at startup
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-29 13:49 EST by Steven Garrity
Modified: 2013-04-02 00:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-14 13:00:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Garrity 2004-11-29 13:49:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I'm running FC3 on my ThinkPad T30. I did a clean install, and I'm not
sure if it started right after the install, or later on, but now each
time I boot, after logging in, I get this error dialog:

> There was an error starting the GNOME Settings Daemon.
> Some things, such as themes, sounds, or background settings 
> may not work correctly.
> The Settings Daemon restarted too many times.
> The last error message was:
> Failed to execute /usr/libexec/gnome-settings-daemon: 27 
> (File too large)
> GNOME will still try to restart the Settings Daemon next 
> time you log in.

Like the error suggests, I do have trouble changing themes and
screensaver preferences. Ideas of what might be wrong and what I could
do to fix it are appreciated.

Here's a screenshot of the error dialog:
http://actsofvolition.com/images/screenshots/gnome-settings-daemon-error.png

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot up
2. After Gnome starts up, the error dialog appears
Comment 1 Mark McLoughlin 2004-12-14 12:55:01 EST
Can you run /usr/libexec/gnome-settings-daemon manually?
Comment 2 Steven Garrity 2004-12-14 13:00:30 EST
Update: Since it said that the /usr/libexec/gnome-settings-daemon
files was "too large", I checked it out and it turned out to be
enormous (like 3Gb). I ran fsck and I had a whole slew of disk
problems (I *think* related to fast and lose partitioning I had done).

I reinstalled the package and all is well now.

Marking: NOTABUG

Sorry for the trouble.

Note You need to log in before you can comment on or make changes to this bug.