Bug 1411708 - s390x wiredtiger unittests failure
Summary: s390x wiredtiger unittests failure
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mongodb
Version: rawhide
Hardware: s390x
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Skalický
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2017-01-10 11:08 UTC by Marek Skalický
Modified: 2017-01-13 12:14 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-13 12:14:28 UTC
Type: Bug


Attachments (Terms of Use)
Log from running failing unittests (24.07 KB, text/plain)
2017-01-10 11:08 UTC, Marek Skalický
no flags Details


Links
System ID Private Priority Status Summary Last Updated
IBM Linux Technology Center 150406 0 None None None 2017-01-10 16:03:28 UTC

Description Marek Skalický 2017-01-10 11:08:06 UTC
Created attachment 1239047 [details]
Log from running failing unittests

Description of problem:
On s390x machine some MongoDB storage driver unittests are failing.

Version-Release number of selected component (if applicable):
mongodb-3.4.1-2 RPM from Fedora rawhide - http://pkgs.fedoraproject.org/cgit/rpms/mongodb.git/tree/
(building without using system libraries and using bundled one, result in same failure)

How reproducible:
- rebuilding RPM from Fedora Rawhide

- build MongoDB 3.4.1 from source with these commands:
$ cat > variables.list
CFLAGS="-O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=z9-109 -mtune=z10"
LINKFLAGS="-Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -Wl,-z,noexecstack -Wl,--reduce-memory-overheads,--no-keep-memory"
CPPDEFINES="BOOST_OPTIONAL_USE_SINGLETON_DEFINITION_OF_NONE "
VERBOSE=1


$ scons all -j4 --ssl --nostrip --disable-warnings-as-errors --variables-files=variables.list

and run unittest testsuite:
$./buildscripts/resmoke.py --dbpathPrefix ./var --continueOnFailure --nopreallocj --suites unittests --storageEngine=wiredTiger



Actual results:
[resmoke] 2017-01-09T10:45:13.523+0000 Summary of unittests suite: 306 test(s) ran in 826.50 seconds (302 succeeded, 0 were skipped, 4 failed, 0 errored)
    cpp_unit_tests: 306 test(s) ran in 826.50 seconds (302 succeeded, 0 were skipped, 4 failed, 0 errored)
        The following tests failed (with exit code):
            build/opt/mongo/db/storage/wiredtiger/storage_wiredtiger_index_test (-4)
            build/opt/mongo/db/storage/wiredtiger/storage_wiredtiger_kv_engine_test (-4)
            build/opt/mongo/db/storage/wiredtiger/storage_wiredtiger_record_store_test (-4)
            build/opt/mongo/db/storage/wiredtiger/storage_wiredtiger_util_test (-4)


Expected results:
All unittests in testsuite passes

Additional info:
Upstream bug - https://jira.mongodb.org/browse/SERVER-27620

Comment 1 IBM Bug Proxy 2017-01-12 07:41:07 UTC
------- Comment From hannsj_uhl@de.ibm.com 2017-01-12 02:32 EDT-------
Comment from  Cindy Lee 2017-01-11 12:58:39 CST

Upstream bug at https://jira.mongodb.org/browse/SERVER-27620
has latest update from mongoDB now, they seem to be aware of it too,
they provide solution there.
Looks like all you need to do is put a flag of --use-s390x-crc32=off

Comment 2 Marek Skalický 2017-01-13 12:14:28 UTC
Thanks. It is working with this flag.
However it would be nice to be able to detect presence of z13 (~having CRC32 instructions) on runtime...

Closing this bugs - it is fixed in Fedora Rawhide.


Note You need to log in before you can comment on or make changes to this bug.