Bug 1411726 - Network notifications not showing on RHEL 7
Summary: Network notifications not showing on RHEL 7
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1527213
TreeView+ depends on / blocked
 
Reported: 2017-01-10 11:45 UTC by Oliver Ilian
Modified: 2018-02-12 18:44 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-12 18:44:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Oliver Ilian 2017-01-10 11:45:16 UTC
Description of problem:
The network notification for connection to either Network, wireless or VPN connections are not shown in Gnome 3.

Version-Release number of selected component (if applicable):
nm-connection-editor-1.4.0-2.el7.x86_64
gnome-shell-3.14.4-53.el7.x86_64

Steps to Reproduce:
1. disconnect from wired network
2. connect to wired network

Actual results:
No notification that you are connected to a network

Expected results:
Notification that you are connected to a network

Additional info:
We were looking to use the Cisco VPN option to present a message after the user logged in. This was working on RHEL 6, and works while using vpnc on the command line.

The settings in Dconf are not disabled (and I did reset them with the following commands:

gsettings reset org.gnome.nm-applet disable-connected-notifications
gsettings reset org.gnome.nm-applet disable-disconnected-notifications

gsettings reset org.gnome.nm-applet disable-wifi-create
gsettings reset org.gnome.nm-applet suppress-wireless-networks-available

gsettings reset org.gnome.nm-applet disable-vpn-notifications

Comment 3 Florian Müllner 2018-02-06 19:22:02 UTC
(In reply to Oliver Haessler from comment #0)
> Description of problem:
> The network notification for connection to either Network, wireless or VPN
> connections are not shown in Gnome 3.

That's because GNOME 3 has built-in network indicator support instead of relying on nm-applet. That is this:

> The settings in Dconf are not disabled (and I did reset them with the
> following commands:
> 
> gsettings reset org.gnome.nm-applet disable-connected-notifications
> gsettings reset org.gnome.nm-applet disable-disconnected-notifications
> 
> gsettings reset org.gnome.nm-applet disable-wifi-create
> gsettings reset org.gnome.nm-applet suppress-wireless-networks-available
> 
> gsettings reset org.gnome.nm-applet disable-vpn-notifications

configures a component that isn't used, and the one that *is* used doesn't follow those settings.

IMHO this is not a regression (if we changed the default browser from Firefox to Chromium, I would not expect the latter to follow the settings of the previous default browser either), but a feature request.

Also I would rather avoid copying nm-applet's settings one-by-one if possible, so can we pin down what feature exactly is missing? We do show notifications when a connection has been lost, what you want is another one when a connection has been established?

Comment 4 Matthias Clasen 2018-02-12 18:44:47 UTC
This behavior is unchanged since 7.0, I don't think it qualifies as a blocker.
The best option for the CSB is a small shell extension, maybe ?
We can probably help with writing one. Setting devack- to get this off the blocker list.

Comment 5 Red Hat Bugzilla Rules Engine 2018-02-12 18:44:54 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.


Note You need to log in before you can comment on or make changes to this bug.