Bug 1411784 - newt-based apps consumes 100% cpu if tty is lost
Summary: newt-based apps consumes 100% cpu if tty is lost
Keywords:
Status: CLOSED DUPLICATE of bug 917291
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: newt
Version: 6.8
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Miroslav Lichvar
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 13:30 UTC by Roman Valov
Modified: 2017-01-10 14:52 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-10 14:52:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Roman Valov 2017-01-10 13:30:10 UTC
Description of problem:


Version-Release number of selected component (if applicable):
0.52.11

How reproducible:
always

Steps to Reproduce:
1. login via ssh
2. python /usr/share/doc/newt-python-0.52.11/peanuts.py &
3. login on another terminal and kill previously opened ssh session

Actual results:
python keeps running consuming up to 100% cpu

Expected results:
Terminal sessions killed with all of its children.

Additional info:
It seems the problem has been already fixed in newer versions of newt library, at least it's not reproduced on RHEL7 with newt 0.52.15.

check this issue: https://bugzilla.redhat.com/show_bug.cgi?id=912774
commit: https://pagure.io/newt/c/b8b8a86f22d08216328dffb8d70b3ae67629a905?branch=master

So, update of newt library to at least 0.52.13 or newer is proposed.

Comment 1 Miroslav Lichvar 2017-01-10 14:52:09 UTC
This bug should be fixed in RHEL6.9.

*** This bug has been marked as a duplicate of bug 917291 ***


Note You need to log in before you can comment on or make changes to this bug.