Bug 141179 - Guided Bug entry flow is difficult to use.
Guided Bug entry flow is difficult to use.
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
Mike MacKenzie
https://bugzilla.redhat.com/beta/easy...
:
Depends On:
Blocks: BZ_218_Final
  Show dependency treegraph
 
Reported: 2004-11-29 14:23 EST by Jesus M. Rodriguez
Modified: 2007-04-18 13:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-02 15:51:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesus M. Rodriguez 2004-11-29 14:23:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001
Firefox/0.10.1

Description of problem:
Guided bug entry should have no more than a single step per page.
Initially, the page offers steps 1 & 2.  Then step 3 is a button.
https://bugzilla.redhat.com/beta/easy_enter_bug.cgi
                                                                     
               
Normally, when one uses a guided wizard-like application each step
is a separate page and only asks for a small amount of information
to be sent in.  Here is what I would expect a workflow to look
like.
                                                                     
               
Step 1 should be auto-detected, as I am already logged in and still
get this option.
                                                                     
               
Step 2, is this really a step in creating a bug or a best practice?
                                                                     
               
Step 3, choosing the product is a good page.
                                                                     
               
Step 4 and Step 5 should be separate pages.
                                                                     
               
Step 6 button, "Additional Information" takes you to a page labeled
"Step 5. Additional Information" Followed at the bottom as "Step 6.
Submit your bug to Bugzilla".
                                                                     
               
I would think this would be a better flow.
                                                                     
               
1. User click on "Enter Bug (Guided)"
2a. If user is not logged in, show Step 1:
                                                                     
               
   Step 1. Create an account or log in.
                                                                     
               
   Create an account if you do not already have one by going to
   CREATE ACCOUNT.  After you receive your password, go ahead
   and LOG IN.
                                                                     
               
2b. If user IS logged in, go directly to "Best Practices" page
   which is required for everyone to read that suggests that
   a user search for a bug before writing up a new one.  After
   a user reads it, he/she should check a box to avoid having
   to read it again.  Then they are taken to Step 3.
                                                                     
               
3. Step 3 should be the "Choosing Your Product" page. User
   chooses a product and goes to Step 4.
                                                                     
               
4. Step 4, "Choosing Component", user should see only the components
   of a product.  They should choose a component and click a button
   to go to Step 5 "Choosing Version and Architecture"
                                                                     
               
5. Step 5, should be its own page with a version and platform list
   and button for                                             
                                        
6. Step 6, should be labeled "Step 6. Additional Information."
   User enters bug information, and clicks a button labeled"
   Step 7 "Review"
                                                                     
               
7. Step 7 puts a read only view of the bug in the format that
   is shown when looking at bugs in Bugzilla.  The page should
   have a button at the bottom called "Submit Bug to Bugzilla".
                                                                     
               
8. A confirmation page (not a new browser window) shows up
stating "Bug xxxx was submitted."
 Step 6. "Additional Information".


Version-Release number of selected component (if applicable):
2.18rC (beta)

How reproducible:
Always

Steps to Reproduce:
1. Go to url above: https://bugzilla.redhat.com/beta/easy_enter_bug.cgi
2. Notice page one has Step 1 and 2.
3. Click button, "Step 3. Choosing Product"
4. Choose a product, say "Red Hat Network".
5. Click button, "Step 4. Choosing Component".
6. Notice resulting page has both Steps 4 and 5. This is bad.
7. Choose RHN/R&D as the component
8. Choose RHN Devel as the version
9. Chooose ALL as the platform
10. "Click Step 6. Additional Information"
11. Notice the resulting page is labeled "Step 5. Additional Information".
12. Also notice that Step 6 (which should be Step 7) is also
   on this page.  Another no-no.
13. Enter bug data
14. Click "Submit Bug to Bugzilla".
15. A new browser window is opened with the bug information.
    A new window should NOT be opened.


Actual Results:  Guided bug entry is non-intuitive.
1. Multiple steps per page
2. new browser window opened when click "Submit Bug to Bugzilla"
3. User presented a Search for bug as Step 2, when this is not
   necessary to actually create a bug, but a best practice.

Expected Results:  1. one step per page
2. no new browser window after submitting bug
3. step 2 should be in a best practice document which is
   shown to users ONCE after first using the easy bug submit
4. Step 1 (login/create account) should ONLY be presented if
   the user is NOT already logged in.

Additional info:
Comment 1 Jesus M. Rodriguez 2004-12-02 14:36:41 EST
Same is true for BETA 3.
https://bugzilla.redhat.com/beta3/easy_enter_bug.cgi
Comment 2 David Lawrence 2005-03-02 14:35:03 EST
I have made some changes based on yours and other suggestions. I have currently
added the new code to the current beta so please take a moment to look at some
of the differences. Mainly I have gotten rid of Step numbers and just have each
button to be a Continue button instead. This is similar to http://bugs.kde.org
and their bug wizard. Also I broke the component selection into it's own page. I
also rearranged the version and platform pages to flow better. Please let me
know what you think.
Comment 3 Jesus M. Rodriguez 2005-03-02 15:43:57 EST
Now we're talking.  This is much more a guided/wizard type of system now.  Even
though there is a lot of information on the page, I actually don't have to read
it all since the pertinent information is easily visible.

Great job!
Comment 4 David Lawrence 2005-03-02 15:51:10 EST
<whew> Cool, thanks for the input. I am sure there is quite a bit of room for
improvement. But I would like to address that after the beta is pushed to
production. Closing out.

Note You need to log in before you can comment on or make changes to this bug.